aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mpc85xx/patches-4.14/100-powerpc-85xx-tl-wdr4900-v1-support.patch
diff options
context:
space:
mode:
authorMagnus Kroken <mkroken@gmail.com>2018-10-06 01:46:22 +0200
committerJohn Crispin <john@phrozen.org>2018-10-11 08:03:56 +0200
commitc83c1804891ac706f2e82f9d6c0aaf6ba290348a (patch)
tree3204894923b23007ea2b2bce988bb8c17cb2a482 /target/linux/mpc85xx/patches-4.14/100-powerpc-85xx-tl-wdr4900-v1-support.patch
parentf4b7dfcc4beede9acd8f503b121aed158e38a11d (diff)
downloadupstream-c83c1804891ac706f2e82f9d6c0aaf6ba290348a.tar.gz
upstream-c83c1804891ac706f2e82f9d6c0aaf6ba290348a.tar.bz2
upstream-c83c1804891ac706f2e82f9d6c0aaf6ba290348a.zip
mpc85xx: add kernel 4.14 support
Based on patches previously submitted by Achim Gottinger: http://lists.infradead.org/pipermail/openwrt-devel/2018-June/012719.html Tested on TP-Link TL-WDR4900 v1. Signed-off-by: Magnus Kroken <mkroken@gmail.com>
Diffstat (limited to 'target/linux/mpc85xx/patches-4.14/100-powerpc-85xx-tl-wdr4900-v1-support.patch')
-rw-r--r--target/linux/mpc85xx/patches-4.14/100-powerpc-85xx-tl-wdr4900-v1-support.patch79
1 files changed, 79 insertions, 0 deletions
diff --git a/target/linux/mpc85xx/patches-4.14/100-powerpc-85xx-tl-wdr4900-v1-support.patch b/target/linux/mpc85xx/patches-4.14/100-powerpc-85xx-tl-wdr4900-v1-support.patch
new file mode 100644
index 0000000000..b99d0da863
--- /dev/null
+++ b/target/linux/mpc85xx/patches-4.14/100-powerpc-85xx-tl-wdr4900-v1-support.patch
@@ -0,0 +1,79 @@
+From 406d86e5990ac171f18ef6e2973672d8fbfe1556 Mon Sep 17 00:00:00 2001
+From: Gabor Juhos <juhosg@openwrt.org>
+Date: Wed, 20 Feb 2013 08:40:33 +0100
+Subject: [PATCH] powerpc: 85xx: add support for the TP-Link TL-WDR4900 v1
+ board
+
+This patch adds support for the TP-Link TL-WDR4900 v1
+concurrent dual-band wireless router. The devices uses
+the Freescale P1014 SoC.
+
+Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
+---
+ arch/powerpc/boot/Makefile | 3 +
+ arch/powerpc/boot/wrapper | 4 +
+ arch/powerpc/platforms/85xx/Kconfig | 11 ++
+ arch/powerpc/platforms/85xx/Makefile | 1 +
+
+--- a/arch/powerpc/boot/Makefile
++++ b/arch/powerpc/boot/Makefile
+@@ -151,6 +151,7 @@ src-plat-$(CONFIG_PPC_PSERIES) += pserie
+ src-plat-$(CONFIG_PPC_POWERNV) += pseries-head.S
+ src-plat-$(CONFIG_PPC_IBM_CELL_BLADE) += pseries-head.S
+ src-plat-$(CONFIG_MVME7100) += motload-head.S mvme7100.c
++src-plat-$(CONFIG_TL_WDR4900_V1) += cuboot-tl-wdr4900-v1.c
+
+ src-wlib := $(sort $(src-wlib-y))
+ src-plat := $(sort $(src-plat-y))
+@@ -330,7 +331,7 @@ image-$(CONFIG_TQM8555) += cuImage.tqm
+ image-$(CONFIG_TQM8560) += cuImage.tqm8560
+ image-$(CONFIG_SBC8548) += cuImage.sbc8548
+ image-$(CONFIG_KSI8560) += cuImage.ksi8560
+-
++image-$(CONFIG_TL_WDR4900_V1) += cuImage.tl-wdr4900-v1
+ # Board ports in arch/powerpc/platform/86xx/Kconfig
+ image-$(CONFIG_MVME7100) += dtbImage.mvme7100
+
+--- a/arch/powerpc/boot/wrapper
++++ b/arch/powerpc/boot/wrapper
+@@ -277,6 +277,10 @@ cuboot*)
+ *-mpc85*|*-tqm85*|*-sbc85*)
+ platformo=$object/cuboot-85xx.o
+ ;;
++ *-tl-wdr4900-v1)
++ platformo=$object/cuboot-tl-wdr4900-v1.o
++ link_address='0x1000000'
++ ;;
+ *-amigaone)
+ link_address='0x800000'
+ ;;
+--- a/arch/powerpc/platforms/85xx/Kconfig
++++ b/arch/powerpc/platforms/85xx/Kconfig
+@@ -170,6 +170,17 @@ config STX_GP3
+ select CPM2
+ select DEFAULT_UIMAGE
+
++config TL_WDR4900_V1
++ bool "TP-Link TL-WDR4900 v1"
++ select DEFAULT_UIMAGE
++ select ARCH_REQUIRE_GPIOLIB
++ select GPIO_MPC8XXX
++ help
++ This option enables support for the TP-Link TL-WDR4900 v1 board.
++
++ This board is a Concurrent Dual-Band wireless router with a
++ Freescale P1014 SoC.
++
+ config TQM8540
+ bool "TQ Components TQM8540"
+ help
+--- a/arch/powerpc/platforms/85xx/Makefile
++++ b/arch/powerpc/platforms/85xx/Makefile
+@@ -26,6 +26,7 @@ obj-$(CONFIG_CORENET_GENERIC) += coren
+ obj-$(CONFIG_FB_FSL_DIU) += t1042rdb_diu.o
+ obj-$(CONFIG_STX_GP3) += stx_gp3.o
+ obj-$(CONFIG_TQM85xx) += tqm85xx.o
++obj-$(CONFIG_TL_WDR4900_V1) += tl_wdr4900_v1.o
+ obj-$(CONFIG_SBC8548) += sbc8548.o
+ obj-$(CONFIG_PPA8548) += ppa8548.o
+ obj-$(CONFIG_SOCRATES) += socrates.o socrates_fpga_pic.o