aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mpc85xx/patches-4.19/101-powerpc-85xx-hiveap-330-support.patch
diff options
context:
space:
mode:
authorPawel Dembicki <paweldembicki@gmail.com>2019-01-01 11:16:32 +0000
committerChristian Lamparter <chunkeey@gmail.com>2019-01-05 22:09:08 +0100
commit36d45e4cdc611c3c935c69aa0e7c8c4418963c6d (patch)
tree71eb9f6389d9a64654dcf41dcb1802ed1f3df243 /target/linux/mpc85xx/patches-4.19/101-powerpc-85xx-hiveap-330-support.patch
parent0fbd3d23aadee0d95beef4f077a866dae7f4841a (diff)
downloadupstream-36d45e4cdc611c3c935c69aa0e7c8c4418963c6d.tar.gz
upstream-36d45e4cdc611c3c935c69aa0e7c8c4418963c6d.tar.bz2
upstream-36d45e4cdc611c3c935c69aa0e7c8c4418963c6d.zip
mpc85xx: add kernel 4.19 support
Copied config from 4.14 Add patches for 4.19 Drop patch 103-powerpc-fix-build-cross32ar.patch, because issue was fixed in upstream. Compiled: generic p1020 Compiled and tested: (unofficial) P2020, TP-Link TL-WDR4900 Signed-off-by: Pawel Dembicki <paweldembicki@gmail.com> Signed-off-by: Christian Lamparter <chunkeey@gmail.com> [reworded commit]
Diffstat (limited to 'target/linux/mpc85xx/patches-4.19/101-powerpc-85xx-hiveap-330-support.patch')
-rw-r--r--target/linux/mpc85xx/patches-4.19/101-powerpc-85xx-hiveap-330-support.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/target/linux/mpc85xx/patches-4.19/101-powerpc-85xx-hiveap-330-support.patch b/target/linux/mpc85xx/patches-4.19/101-powerpc-85xx-hiveap-330-support.patch
new file mode 100644
index 0000000000..34568398c2
--- /dev/null
+++ b/target/linux/mpc85xx/patches-4.19/101-powerpc-85xx-hiveap-330-support.patch
@@ -0,0 +1,30 @@
+--- a/arch/powerpc/platforms/85xx/Kconfig
++++ b/arch/powerpc/platforms/85xx/Kconfig
+@@ -49,6 +49,17 @@ config BSC9132_QDS
+ and dual StarCore SC3850 DSP cores.
+ Manufacturer : Freescale Semiconductor, Inc
+
++config HIVEAP_330
++ bool "Aerohive HiveAP-330"
++ select DEFAULT_UIMAGE
++ select ARCH_REQUIRE_GPIOLIB
++ select GPIO_MPC8XXX
++ help
++ This option enables support for the Aerohive HiveAP-330 board.
++
++ This board is a Concurrent Dual-Band wireless access point with a
++ Freescale P1020 SoC.
++
+ config MPC8540_ADS
+ bool "Freescale MPC8540 ADS"
+ select DEFAULT_UIMAGE
+--- a/arch/powerpc/platforms/85xx/Makefile
++++ b/arch/powerpc/platforms/85xx/Makefile
+@@ -10,6 +10,7 @@ obj-y += common.o
+ obj-$(CONFIG_BSC9131_RDB) += bsc913x_rdb.o
+ obj-$(CONFIG_BSC9132_QDS) += bsc913x_qds.o
+ obj-$(CONFIG_C293_PCIE) += c293pcie.o
++obj-$(CONFIG_HIVEAP_330) += hiveap-330.o
+ obj-$(CONFIG_MPC8540_ADS) += mpc85xx_ads.o
+ obj-$(CONFIG_MPC8560_ADS) += mpc85xx_ads.o
+ obj-$(CONFIG_MPC85xx_CDS) += mpc85xx_cds.o