aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mvebu/image/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2016-11-21 11:59:37 +0100
committerFelix Fietkau <nbd@nbd.name>2016-11-24 12:53:17 +0100
commit9fc0bcdd18688724494e3364ec986318372129a4 (patch)
treebcbcaab9641b9a48e2a2ed876981d25fe99739e3 /target/linux/mvebu/image/Makefile
parentd596c21ebd5a3e6ce933eff3e51989031e4b1d58 (diff)
downloadupstream-9fc0bcdd18688724494e3364ec986318372129a4.tar.gz
upstream-9fc0bcdd18688724494e3364ec986318372129a4.tar.bz2
upstream-9fc0bcdd18688724494e3364ec986318372129a4.zip
mvebu: use image metadata for firmware validation
Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'target/linux/mvebu/image/Makefile')
-rw-r--r--target/linux/mvebu/image/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/target/linux/mvebu/image/Makefile b/target/linux/mvebu/image/Makefile
index 73c533ab37..8b203a4122 100644
--- a/target/linux/mvebu/image/Makefile
+++ b/target/linux/mvebu/image/Makefile
@@ -61,11 +61,12 @@ define Device/Default
BOARD_NAME = $$(DEVICE_DTS)
KERNEL_NAME := zImage
KERNEL := kernel-bin | append-dtb | uImage none
+ SUPPORTED_DEVICES = $$(DEVICE_DTS)
endef
define Device/UBI
IMAGES := sysupgrade.bin
- IMAGE/sysupgrade.bin := sysupgrade-tar
+ IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
endef
define Device/UBI-factory
@@ -146,6 +147,7 @@ TARGET_DEVICES += linksys-wrt1900ac
define Device/openblocks-ax3
$(Device/UBI-factory)
DEVICE_DTS := armada-xp-openblocks-ax3-4
+ SUPPORTED_DEVCES := $(1)
BLOCKSIZE := 128k
PAGESIZE := 1
IMAGE/factory.img := append-kernel | pad-to $$(BLOCKSIZE) | append-ubi
@@ -194,6 +196,7 @@ TARGET_DEVICES += armada-388-clearfog
define Device/globalscale-mirabox
$(Device/NAND-512K)
DEVICE_DTS := armada-370-mirabox
+ SUPPORTED_DEVCES := mirabox
DEVICE_TITLE := Globalscale Mirabox
endef
TARGET_DEVICES += globalscale-mirabox