aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/orion/patches-3.18/200-dt2_board_support.patch
diff options
context:
space:
mode:
authorStijn Tintel <stijn@linux-ipv6.be>2016-08-14 23:45:42 +0300
committerJohn Crispin <john@phrozen.org>2016-08-15 15:32:37 +0200
commit74aecc2d450938ce9c3e157b60f8277e68908c65 (patch)
treee29f6b09d6c85ef3971be1bea232123edf6611d1 /target/linux/orion/patches-3.18/200-dt2_board_support.patch
parentd99169536e9b4245304c545a25abab747f619e8d (diff)
downloadupstream-74aecc2d450938ce9c3e157b60f8277e68908c65.tar.gz
upstream-74aecc2d450938ce9c3e157b60f8277e68908c65.tar.bz2
upstream-74aecc2d450938ce9c3e157b60f8277e68908c65.zip
orion: rename patches directory to patches-3.18
Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
Diffstat (limited to 'target/linux/orion/patches-3.18/200-dt2_board_support.patch')
-rw-r--r--target/linux/orion/patches-3.18/200-dt2_board_support.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/target/linux/orion/patches-3.18/200-dt2_board_support.patch b/target/linux/orion/patches-3.18/200-dt2_board_support.patch
new file mode 100644
index 0000000000..59a377f336
--- /dev/null
+++ b/target/linux/orion/patches-3.18/200-dt2_board_support.patch
@@ -0,0 +1,26 @@
+--- a/arch/arm/mach-orion5x/Kconfig
++++ b/arch/arm/mach-orion5x/Kconfig
+@@ -36,6 +36,13 @@ config MACH_RD88F5182_DT
+ Say 'Y' here if you want your kernel to support the Marvell
+ Orion-NAS (88F5182) RD2, Flattened Device Tree.
+
++config MACH_DT2
++ bool "Freecom DataTank Gateway"
++ select I2C_BOARDINFO
++ help
++ Say 'Y' here if you want your kernel to support the
++ Freecom DataTank Gateway
++
+ config MACH_KUROBOX_PRO
+ bool "KuroBox Pro"
+ select I2C_BOARDINFO
+--- a/arch/arm/mach-orion5x/Makefile
++++ b/arch/arm/mach-orion5x/Makefile
+@@ -14,6 +14,7 @@ obj-$(CONFIG_MACH_TS78XX) += ts78xx-setu
+ obj-$(CONFIG_MACH_MV2120) += mv2120-setup.o
+ obj-$(CONFIG_MACH_NET2BIG) += net2big-setup.o
+ obj-$(CONFIG_MACH_WNR854T) += wnr854t-setup.o
++obj-$(CONFIG_MACH_DT2) += dt2-setup.o
+ obj-$(CONFIG_MACH_RD88F5181L_GE) += rd88f5181l-ge-setup.o
+ obj-$(CONFIG_MACH_RD88F5181L_FXO) += rd88f5181l-fxo-setup.o
+ obj-$(CONFIG_MACH_RD88F6183AP_GE) += rd88f6183ap-ge-setup.o