aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/oxnas/patches-3.18/330-oxnas-pinctrl.patch
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2014-11-26 09:00:08 +0000
committerJohn Crispin <john@openwrt.org>2014-11-26 09:00:08 +0000
commit72b58f2eb12ad4aa0c59481d0911dc5e39180eb5 (patch)
treebe51e2d36c4175443bd3ab42824df80c6b9a2efe /target/linux/oxnas/patches-3.18/330-oxnas-pinctrl.patch
parent40da7aae54ad7f098064f18e28eb8201afedfd5c (diff)
downloadupstream-72b58f2eb12ad4aa0c59481d0911dc5e39180eb5.tar.gz
upstream-72b58f2eb12ad4aa0c59481d0911dc5e39180eb5.tar.bz2
upstream-72b58f2eb12ad4aa0c59481d0911dc5e39180eb5.zip
add new target 'oxnas'
This is the oxnas target previously developed at http://gitorious.org/openwrt-oxnas Basically, this consolidates the changes and addtionas from http://github.org/kref/linux-oxnas into a new OpenWrt hardware target 'oxnas' adding support for PLX Technology NAS7820/NAS7821/NAS7825/... formally known as Oxford Semiconductor OXE810SE/OXE815/OX820/... For now there are 4 supported boards: Cloud Engines Pogoplug V3 (without PCIe) fully supported Cloud Engines Pogoplug Pro (with PCIe) fully supported MitraStar STG-212 aka ZyXEL NSA-212, aka Medion Akoya P89625 / P89636 / P89626 / P89630, aka Medion MD 86407 / MD 86805 / MD 86517 / MD 86587 fully supported, see http://wiki.openwrt.org/toh/medion/md86587 Shuttle KD-20 partially supported (S-ATA driver lacks support for 2nd port) Signed-off-by: Daniel Golle <daniel@makrotopia.org> SVN-Revision: 43388
Diffstat (limited to 'target/linux/oxnas/patches-3.18/330-oxnas-pinctrl.patch')
-rw-r--r--target/linux/oxnas/patches-3.18/330-oxnas-pinctrl.patch32
1 files changed, 32 insertions, 0 deletions
diff --git a/target/linux/oxnas/patches-3.18/330-oxnas-pinctrl.patch b/target/linux/oxnas/patches-3.18/330-oxnas-pinctrl.patch
new file mode 100644
index 0000000000..3ecc6ebe77
--- /dev/null
+++ b/target/linux/oxnas/patches-3.18/330-oxnas-pinctrl.patch
@@ -0,0 +1,32 @@
+Index: linux-3.18-rc4/drivers/pinctrl/Kconfig
+===================================================================
+--- linux-3.18-rc4.orig/drivers/pinctrl/Kconfig
++++ linux-3.18-rc4/drivers/pinctrl/Kconfig
+@@ -67,6 +67,15 @@ config PINCTRL_AT91
+ help
+ Say Y here to enable the at91 pinctrl driver
+
++config PINCTRL_OXNAS
++ bool "OXNAS pinctrl driver"
++ depends on OF
++ depends on ARCH_OXNAS
++ select PINMUX
++ select PINCONF
++ help
++ Say Y here to enable the oxnas pinctrl driver
++
+ config PINCTRL_BAYTRAIL
+ bool "Intel Baytrail GPIO pin control"
+ depends on GPIOLIB && ACPI && X86
+Index: linux-3.18-rc4/drivers/pinctrl/Makefile
+===================================================================
+--- linux-3.18-rc4.orig/drivers/pinctrl/Makefile
++++ linux-3.18-rc4/drivers/pinctrl/Makefile
+@@ -18,6 +18,7 @@ obj-$(CONFIG_PINCTRL_BCM2835) += pinctrl
+ obj-$(CONFIG_PINCTRL_BAYTRAIL) += pinctrl-baytrail.o
+ obj-$(CONFIG_PINCTRL_BCM281XX) += pinctrl-bcm281xx.o
+ obj-$(CONFIG_PINCTRL_FALCON) += pinctrl-falcon.o
++obj-$(CONFIG_PINCTRL_OXNAS) += pinctrl-oxnas.o
+ obj-$(CONFIG_PINCTRL_PALMAS) += pinctrl-palmas.o
+ obj-$(CONFIG_PINCTRL_ROCKCHIP) += pinctrl-rockchip.o
+ obj-$(CONFIG_PINCTRL_SINGLE) += pinctrl-single.o