aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ppc40x/image/Makefile
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2019-03-25 15:16:59 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2019-05-03 21:27:12 +0200
commit406a3826dcbb48b5ea42f2d9e96ff92721a6440a (patch)
treeb011553d768a38899ae8522ad2c7348320b3f551 /target/linux/ppc40x/image/Makefile
parent65cdfbabde3dbbc924233f2b8f01a356e0c74e7e (diff)
downloadupstream-406a3826dcbb48b5ea42f2d9e96ff92721a6440a.tar.gz
upstream-406a3826dcbb48b5ea42f2d9e96ff92721a6440a.tar.bz2
upstream-406a3826dcbb48b5ea42f2d9e96ff92721a6440a.zip
ppc40x: Remove unmaintained target
This target only supports kernel 3.18, which is not supported in OpenWrt any more for multiple releases. It also looks like there is no active maintainer for this target. Remove the code and all the packages which are only used by this target. To add this target to OpenWrt again port it to a recent and supported kernel version. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Diffstat (limited to 'target/linux/ppc40x/image/Makefile')
-rw-r--r--target/linux/ppc40x/image/Makefile72
1 files changed, 0 insertions, 72 deletions
diff --git a/target/linux/ppc40x/image/Makefile b/target/linux/ppc40x/image/Makefile
deleted file mode 100644
index 4070774296..0000000000
--- a/target/linux/ppc40x/image/Makefile
+++ /dev/null
@@ -1,72 +0,0 @@
-#
-# Copyright (C) 2008-2013 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-include $(TOPDIR)/rules.mk
-include $(INCLUDE_DIR)/image.mk
-
-JFFS2_BLOCKSIZE=128k 64k
-
-define Image/Prepare
- $(LINUX_DIR)/scripts/dtc/dtc -O dtb -R 4 -S 0x20000 $(DTS_DIR)/kilauea.dts > $(KDIR)/openwrt-kilauea.dtb
-endef
-
-define Image/BuildKernel
- cp $(KDIR)/uImage $(BIN_DIR)/$(IMG_PREFIX)-uImage
- $(call Image/Build/Initramfs)
-endef
-
-define Image/Build
- $(call Image/Build/$(1),$(1))
-endef
-
-define Image/Build/ext2
- cp $(KDIR)/root.$(1) $(BIN_DIR)/$(IMG_PREFIX)-ext2.img
-endef
-
-define Image/Build/jffs2-128k
- ( \
- dd if=$(KDIR)/uImage bs=1920k conv=sync; \
- dd if=$(KDIR)/openwrt-kilauea.dtb bs=128k conv=sync; \
- dd if=$(KDIR)/root.$(1) bs=128k conv=sync; \
- ) > $(BIN_DIR)/$(IMG_PREFIX)-kilauea-jffs2.img
-endef
-
-define Image/Build/jffs2-64k
- ( \
- dd if=$(KDIR)/cuImage.magicbox bs=1408k conv=sync; \
- dd if=$(KDIR)/root.$(1) bs=64k conv=sync; \
- ) > $(BIN_DIR)/$(IMG_PREFIX)-magicbox-jffs2.img
- ( \
- dd if=$(KDIR)/cuImage.openrb bs=1408k conv=sync; \
- dd if=$(KDIR)/root.$(1) bs=64k conv=sync; \
- ) > $(BIN_DIR)/$(IMG_PREFIX)-openrb-jffs2.img
-endef
-
-define Image/Build/squashfs
- $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
- ( \
- dd if=$(KDIR)/uImage bs=1920k conv=sync; \
- dd if=$(KDIR)/openwrt-kilauea.dtb bs=128k conv=sync; \
- dd if=$(KDIR)/root.$(1) bs=128k conv=sync; \
- ) > $(BIN_DIR)/$(IMG_PREFIX)-kilauea-$(1).img
- ( \
- dd if=$(KDIR)/cuImage.magicbox bs=64k conv=sync; \
- dd if=$(KDIR)/root.$(1) bs=64k conv=sync; \
- ) > $(BIN_DIR)/$(IMG_PREFIX)-magicbox-$(1).img
- ( \
- dd if=$(KDIR)/cuImage.openrb bs=1408k conv=sync; \
- dd if=$(KDIR)/root.$(1) bs=64k conv=sync; \
- ) > $(BIN_DIR)/$(IMG_PREFIX)-openrb-$(1).img
-endef
-
-ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),)
-define Image/Build/Initramfs
- cp $(KDIR)/cuImage.magicbox-initramfs $(BIN_DIR)/openwrt-$(BOARD)-magicbox-initramfs.bin
- cp $(KDIR)/cuImage.openrb-initramfs $(BIN_DIR)/openwrt-$(BOARD)-openrb-initramfs.bin
-endef
-endif
-
-$(eval $(call BuildImage))