aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt7620.mk
diff options
context:
space:
mode:
authorSungbo Eo <mans0n@gorani.run>2019-09-27 00:21:25 +0900
committerChuanhong Guo <gch981213@gmail.com>2020-04-18 12:35:54 +0800
commit9169482f640ca840ff478ddd03ee2cb275d21c23 (patch)
tree1b53eca01760224891482928ebfba622ad18a7d2 /target/linux/ramips/image/mt7620.mk
parentd682dcc939dc65dc7603083e27775e4dee577647 (diff)
downloadupstream-9169482f640ca840ff478ddd03ee2cb275d21c23.tar.gz
upstream-9169482f640ca840ff478ddd03ee2cb275d21c23.tar.bz2
upstream-9169482f640ca840ff478ddd03ee2cb275d21c23.zip
ramips: add support for ipTIME A1004ns
ipTIME A1004ns is a 2.4/5GHz band AC750 router, based on MediaTek MT7620A. Specifications: - SoC: MT7620A - RAM: DDR2 128MB - Flash: SPI NOR 16MB - WiFi: - 2.4GHz: SoC internal - 5GHz: MT7610EN - Ethernet: 5x 10/100/1000Mbps - Switch: MT7530BU - USB: 1x 2.0 - UART: - J2: 3.3V, TX, RX, GND (3.3V is the square pad) / 57600 8N1 Installation via web interface: 1. Flash **initramfs** image through the stock web interface. 2. Boot into OpenWrt and perform sysupgrade with sysupgrade image. Revert to stock firmware: 1. Perform sysupgrade with stock image. Signed-off-by: Sungbo Eo <mans0n@gorani.run>
Diffstat (limited to 'target/linux/ramips/image/mt7620.mk')
-rw-r--r--target/linux/ramips/image/mt7620.mk11
1 files changed, 11 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7620.mk b/target/linux/ramips/image/mt7620.mk
index 818fd12de7..69b9b7d7fd 100644
--- a/target/linux/ramips/image/mt7620.mk
+++ b/target/linux/ramips/image/mt7620.mk
@@ -503,6 +503,17 @@ define Device/iodata_wn-ac733gr3
endef
TARGET_DEVICES += iodata_wn-ac733gr3
+define Device/iptime_a1004ns
+ SOC := mt7620a
+ IMAGE_SIZE := 16192k
+ UIMAGE_NAME := a1004ns
+ DEVICE_VENDOR := ipTIME
+ DEVICE_MODEL := A1004ns
+ DEVICE_PACKAGES := kmod-mt76x0e kmod-usb2 kmod-usb-ohci \
+ kmod-usb-ledtrig-usbport
+endef
+TARGET_DEVICES += iptime_a1004ns
+
define Device/iptime_a104ns
SOC := mt7620a
IMAGE_SIZE := 8000k