aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt76x8.mk
diff options
context:
space:
mode:
authorFilip Moc <lede@moc6.cz>2020-11-24 22:15:26 +0100
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-11-25 13:23:06 +0100
commitb641eb6ecfbfc2c6a488483332d4b5a6ee4c736c (patch)
treeb902644d19bed7d697333a10f5332baffbe80b3c /target/linux/ramips/image/mt76x8.mk
parentb31aaa0580c94bc69e1891932f41ff10e5cb2da2 (diff)
downloadupstream-b641eb6ecfbfc2c6a488483332d4b5a6ee4c736c.tar.gz
upstream-b641eb6ecfbfc2c6a488483332d4b5a6ee4c736c.tar.bz2
upstream-b641eb6ecfbfc2c6a488483332d4b5a6ee4c736c.zip
ramips: add support for TP-Link MR6400 v5
TL-MR6400v5 is very similar to TL-MR6400v4. Main differences are: - smaller form factor - different LED GPIOs - different switch connections You can flash via tftp recovery: - serve tftp-recovery image as /tp_recovery.bin on 192.168.0.225/24 - connect to any ethernet port - power on the device while holding the reset button - wait at least 8 seconds before releasing reset button Flashing via OEM web interface does not work. LTE module does not support DHCP so it must be configured via QMI. Hardware Specification (v5.0 EU): - SoC: MT7628NN - Flash: Winbond W25Q64JVS (8MiB) - RAM: ESMT M14D5121632A (64MiB) - Wireless: SoC platform only (2.4GHz b/g/n, 2x internal antenna) - Ethernet: 1NIC (4x100M) - WWAN: TP-LINK LTE MODULE (2x external detachable antenna) - Power: DC 9V 0.85A Signed-off-by: Filip Moc <lede@moc6.cz>
Diffstat (limited to 'target/linux/ramips/image/mt76x8.mk')
-rw-r--r--target/linux/ramips/image/mt76x8.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt76x8.mk b/target/linux/ramips/image/mt76x8.mk
index 30c41420aa..72539f7a14 100644
--- a/target/linux/ramips/image/mt76x8.mk
+++ b/target/linux/ramips/image/mt76x8.mk
@@ -498,6 +498,22 @@ define Device/tplink_tl-mr6400-v4
endef
TARGET_DEVICES += tplink_tl-mr6400-v4
+define Device/tplink_tl-mr6400-v5
+ $(Device/tplink-v2)
+ IMAGE_SIZE := 7808k
+ DEVICE_MODEL := TL-MR6400
+ DEVICE_VARIANT := v5
+ TPLINK_FLASHLAYOUT := 8Mmtk
+ TPLINK_HWID := 0x64000005
+ TPLINK_HWREV := 0x5
+ TPLINK_HWREVADD := 0x5
+ DEVICE_PACKAGES := kmod-usb2 kmod-usb-ohci kmod-usb-ledtrig-usbport \
+ kmod-usb-serial kmod-usb-serial-option kmod-usb-net-qmi-wwan uqmi
+ IMAGES := sysupgrade.bin tftp-recovery.bin
+ IMAGE/tftp-recovery.bin := pad-extra 128k | $$(IMAGE/factory.bin)
+endef
+TARGET_DEVICES += tplink_tl-mr6400-v5
+
define Device/tplink_tl-wa801nd-v5
$(Device/tplink-v2)
IMAGE_SIZE := 7808k