aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorINAGAKI Hiroshi <musashino.open@gmail.com>2019-09-14 00:14:36 +0900
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2021-02-11 16:37:53 +0100
commit08768b44d9b6983ae8d2b96434225fef1f5f664c (patch)
tree59a571239d88c9ce4485bb4ceaea1b92b3e1e7d5 /target/linux/ramips/image
parente95b1b23f1b6951318d6c6caf3803fb933f71a6c (diff)
downloadupstream-08768b44d9b6983ae8d2b96434225fef1f5f664c.tar.gz
upstream-08768b44d9b6983ae8d2b96434225fef1f5f664c.tar.bz2
upstream-08768b44d9b6983ae8d2b96434225fef1f5f664c.zip
ramips: add support for ELECOM WRC-1167FS
ELECOM WRC-1167FS is a 2.4/5 GHz band 11ac (WiFi-5) router, based on MT7628AN. Specification: - SoC : MediaTek MT7628AN - RAM : DDR2 64 MiB (NT5TU32M16FG-AC) - Flash : SPI-NOR 16 MiB (W25Q128JVSIQ) - WLAN : 2.4/5 GHz 2T2R - 2.4 GHz : MediaTek MT7628AN (SoC) - 5 GHz : MediaTek MT7612E - Ethernet : 10/100 Mbps x2 - Switch : MT7628AN (SoC) - LEDs/Keys : 6x, 3x (2x buttons, 1x slide-switch) - UART : through-hole on PCB - J1: 3.3V, GND, TX, RX from "J1" marking - 57600n8 - Power : 12 VDC, 1 A Flash instruction using factory image: 1. Boot WRC-1167FS normally 2. Access to "http://192.168.2.1/" and open firmware update page ("ファームウェア更新") 3. Select the OpenWrt factory image and click apply ("適用") button to perform firmware update 4. Wait ~120 seconds to complete flashing Notes: - Last 0x800000 (8 MiB) in SPI-NOR flash is not used on stock firmware - Additional padding in factory image is required to avoid incomplete flashing on stock firmware MAC addresses: - LAN : BC:5C:4C:xx:xx:68 (Config, ethaddr (text) / Factory, 0x28 (hex)) - WAN : BC:5C:4C:xx:xx:69 (Config, wanaddr (text) / Factory, 0x22 (hex)) - 2.4GHz: BC:5C:4C:xx:xx:6A (Config, rmac (text) / Factory, 0x4 (hex)) - 5GHz : BC:5C:4C:xx:xx:6B (Config, rmac2 (text) / Factory, 0x8004 (hex)) Signed-off-by: INAGAKI Hiroshi <musashino.open@gmail.com>
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/mt76x8.mk27
1 files changed, 27 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt76x8.mk b/target/linux/ramips/image/mt76x8.mk
index 00976f6044..7ba2acacb8 100644
--- a/target/linux/ramips/image/mt76x8.mk
+++ b/target/linux/ramips/image/mt76x8.mk
@@ -6,6 +6,21 @@ include ./common-tp-link.mk
DEFAULT_SOC := mt7628an
+define Build/elecom-header
+ $(eval model_id=$(1))
+ ( \
+ fw_size="$$(printf '%08x' $$(stat -c%s $@))"; \
+ echo -ne "$$(echo "031d6129$${fw_size}06000000$(model_id)" | \
+ sed 's/../\\x&/g')"; \
+ dd if=/dev/zero bs=92 count=1; \
+ data_crc="$$(dd if=$@ | gzip -c | tail -c 8 | \
+ od -An -N4 -tx4 --endian little | tr -d ' \n')"; \
+ echo -ne "$$(echo "$${data_crc}00000000" | sed 's/../\\x&/g')"; \
+ dd if=$@; \
+ ) > $@.new
+ mv $@.new $@
+endef
+
define Build/ravpower-wd009-factory
mkimage -A mips -T standalone -C none -a 0x80010000 -e 0x80010000 \
-n "OpenWrt Bootloader" -d $(UBOOT_PATH) $@.new
@@ -93,6 +108,18 @@ define Device/duzun_dm06
endef
TARGET_DEVICES += duzun_dm06
+define Device/elecom_wrc-1167fs
+ IMAGE_SIZE := 7360k
+ DEVICE_VENDOR := ELECOM
+ DEVICE_MODEL := WRC-1167FS
+ IMAGES += factory.bin
+ IMAGE/factory.bin := $$(sysupgrade_bin) | pad-to 64k | check-size | \
+ xor-image -p 29944A25 -x | elecom-header 00228000 | \
+ elecom-product-header WRC-1167FS
+ DEVICE_PACKAGES := kmod-mt76x2
+endef
+TARGET_DEVICES += elecom_wrc-1167fs
+
define Device/glinet_gl-mt300n-v2
IMAGE_SIZE := 16064k
DEVICE_VENDOR := GL.iNet