aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2011-03-13 16:34:52 +0000
committerGabor Juhos <juhosg@openwrt.org>2011-03-13 16:34:52 +0000
commit23518bb2e400eba4fdaa2b306de049a0378940ed (patch)
tree2c445dc42f998366452e9ca4a00d282164db7e0d /target/linux/ramips/image
parent72cb0af66d5ba2a3bc8971d5e1bb9c607c4f89f1 (diff)
downloadupstream-23518bb2e400eba4fdaa2b306de049a0378940ed.tar.gz
upstream-23518bb2e400eba4fdaa2b306de049a0378940ed.tar.bz2
upstream-23518bb2e400eba4fdaa2b306de049a0378940ed.zip
ramips: initial board support for Aztech HW550-3G
This patch adds initial support for the Aztech HW550-3G (Ralink RT3052f SoC, 8MB flash, 32MB dram). Ethernet is not working yet. Wireless appears to work fine. USB does not work yet (as with other Ralink boards). Signed-off-by: Layne Edwards <ledwards76@gmail.com> SVN-Revision: 26123
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index 79809de9fd..361588efcf 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -100,6 +100,10 @@ define Image/Build/Profile/WHRG300N
$(call Image/Build/Template/GENERIC_4M,$(1),whr-g300n,WHR-G300N)
endef
+define Image/Build/Profile/HW5503G
+ $(call Image/Build/Template/GENERIC_8M,$(1),hw550-3g,HW550-3G)
+endef
+
mtdlayout_wcr150gn=mtdparts=physmap-flash.0:192k(Bootloader)ro,64k(Config),64k(Factory),832k(Kernel),2944k(rootfs),3776k@0x50000(firmware)
mtd_wcr150gn_kernel_part_size=851968
@@ -134,6 +138,7 @@ define Image/Build/Profile/Default
$(call Image/Build/Profile/WHRG300N,$(1))
$(call Image/Build/Profile/WCR150GN,$(1))
$(call Image/Build/Profile/F5D8235V2,$(1))
+ $(call Image/Build/Profile/HW5503G,$(1))
endef
endif