aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorPiotr Dymacz <pepe2k@gmail.com>2017-10-14 10:44:39 +0200
committerPiotr Dymacz <pepe2k@gmail.com>2018-01-15 00:12:13 +0100
commit5352669c2c470f2d2bb02deccfa758e1867e07b0 (patch)
treeefda6c467b3ab2f9a99d3e90e6bba45100a5ec18 /target/linux/ramips/image
parent53e3df2e71e992f7644420e7e362cc4a4a284edc (diff)
downloadupstream-5352669c2c470f2d2bb02deccfa758e1867e07b0.tar.gz
upstream-5352669c2c470f2d2bb02deccfa758e1867e07b0.tar.bz2
upstream-5352669c2c470f2d2bb02deccfa758e1867e07b0.zip
ramips: add support for ALFA Network AC1200RM
ALFA Network AC1200RM is an AC1200 router, with 5-port FE switch and USB 2.0 port. Device is based on MediaTek MT7620A + MT7612EN. Specification: - MT7620A (580 MHz) - 64 MB of RAM (DDR2) - 16 MB of FLASH (SPI NOR) - 5x 10/100 Mbps Ethernet with passive PoE output in WAN and LAN4 - 2T2R 2.4 GHz (MT7620A) - 2T2R 5 GHz (MT7612EN) - 1x USB 2.0 - 9x LED (8 driven by GPIO) - 1x button (reset) - DC jack for main power input (12-24 V) - 2x UART, I2C, I2S and LED headers Flash instruction (do it under U-Boot, using UART and TFTP server): Select option "2: Load system code then write to Flash via TFTP" and use "sysupgrade" image. Signed-off-by: Piotr Dymacz <pepe2k@gmail.com>
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/mt7620.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7620.mk b/target/linux/ramips/image/mt7620.mk
index 902677f3a9..6f9aa1aa6d 100644
--- a/target/linux/ramips/image/mt7620.mk
+++ b/target/linux/ramips/image/mt7620.mk
@@ -27,6 +27,15 @@ define Device/ai-br100
endef
TARGET_DEVICES += ai-br100
+define Device/alfa-network_ac1200rm
+ DTS := AC1200RM
+ IMAGE_SIZE := 16064k
+ DEVICE_TITLE := ALFA Network AC1200RM
+ DEVICE_PACKAGES := kmod-usb2 kmod-usb-ohci
+ SUPPORTED_DEVICES := $(subst _,$(comma),$(1))
+endef
+TARGET_DEVICES += alfa-network_ac1200rm
+
define Device/Archer
TPLINK_HWREVADD := 0
TPLINK_HVERSION := 3