aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorDENG Qingfang <dengqf6@mail2.sysu.edu.cn>2020-03-19 19:43:39 +0800
committerChuanhong Guo <gch981213@gmail.com>2020-04-04 14:56:14 +0800
commit53b66248f4ad4767f19ff243d8f839d9dea15b00 (patch)
tree83b1aa195ea81af08b727ccc233a7338f9ddc558 /target/linux/ramips/image
parent5acd1ed0be0d78847cd7d9d5599526f59babaf4d (diff)
downloadupstream-53b66248f4ad4767f19ff243d8f839d9dea15b00.tar.gz
upstream-53b66248f4ad4767f19ff243d8f839d9dea15b00.tar.bz2
upstream-53b66248f4ad4767f19ff243d8f839d9dea15b00.zip
ramips: use SoC I2C instead of bitbanged for Ubiquiti ER-X-SFP
The original idea of bitbanged I2C is to use i2c-gpio-custom Since i2c-gpio-custom is no longer available on 5.4, use SoC I2C instead Signed-off-by: DENG Qingfang <dengqf6@mail2.sysu.edu.cn>
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/mt7621.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index b2590c5759..cd5be15837 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -785,7 +785,7 @@ define Device/ubiquiti_edgerouterx-sfp
$(Device/ubiquiti_edgerouterx)
DEVICE_VENDOR := Ubiquiti
DEVICE_MODEL := EdgeRouter X-SFP
- DEVICE_PACKAGES += kmod-i2c-algo-pca kmod-gpio-pca953x kmod-i2c-gpio-custom
+ DEVICE_PACKAGES += kmod-i2c-algo-pca kmod-gpio-pca953x
SUPPORTED_DEVICES += ubnt-erx-sfp
endef
TARGET_DEVICES += ubiquiti_edgerouterx-sfp