aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorThibaut VARENE <hacks@slashdirt.org>2017-07-30 12:17:44 +0200
committerMathias Kresin <dev@kresin.me>2017-08-03 00:11:25 +0200
commit695f5ea85a20d14b179053496ff007cb5d947923 (patch)
tree8a1f61918417218a9fcca12d7bbf452d0a422552 /target/linux/ramips/image
parent8a13895a2e3fc749e0038b50e7b6b4988505179b (diff)
downloadupstream-695f5ea85a20d14b179053496ff007cb5d947923.tar.gz
upstream-695f5ea85a20d14b179053496ff007cb5d947923.tar.bz2
upstream-695f5ea85a20d14b179053496ff007cb5d947923.zip
ramips: Add support for Netgear EX3800
The Netgear EX3800 is essentially an EX3700 with a mains output socket. Both devices use the exact same firmware image (original firmware is named EX3700-EX3800-version.chk). This patch adds suport by renaming the EX3700 device to EX3700/EX3800 and updating the necessary glue. Signed-off-by: Thibaut VARENE <hacks@slashdirt.org>
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/mt7620.mk7
1 files changed, 4 insertions, 3 deletions
diff --git a/target/linux/ramips/image/mt7620.mk b/target/linux/ramips/image/mt7620.mk
index 84999f08de..f9a9fdb84c 100644
--- a/target/linux/ramips/image/mt7620.mk
+++ b/target/linux/ramips/image/mt7620.mk
@@ -140,7 +140,7 @@ define Device/ex2700
endef
TARGET_DEVICES += ex2700
-define Device/ex3700
+define Device/ex3700-ex3800
NETGEAR_BOARD_ID := U12H319T00_NETGEAR
DTS := EX3700
BLOCKSIZE := 4k
@@ -148,9 +148,10 @@ define Device/ex3700
IMAGES += factory.chk
IMAGE/factory.chk := $$(sysupgrade_bin) | check-size $$$$(IMAGE_SIZE) | netgear-chk
DEVICE_PACKAGES := -kmod-mt76 kmod-mt76x2
- DEVICE_TITLE := Netgear EX3700
+ DEVICE_TITLE := Netgear EX3700/EX3800
+ SUPPORTED_DEVICES := ex3700
endef
-TARGET_DEVICES += ex3700
+TARGET_DEVICES += ex3700-ex3800
define Device/gl-mt300a
DTS := GL-MT300A