aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorL. D. Pinney <ldpinney@gmail.com>2017-07-22 09:15:56 +0800
committerMathias Kresin <dev@kresin.me>2017-07-25 21:02:53 +0200
commit77645ffcd9ad767be02ea6d5cfe042928a3565d1 (patch)
tree3211ef40796a33dd3dc3dd865fdc15648d6f0e01 /target/linux/ramips/image
parent4faf3149331e80db1e9a7425ad02e3c54492cea5 (diff)
downloadupstream-77645ffcd9ad767be02ea6d5cfe042928a3565d1.tar.gz
upstream-77645ffcd9ad767be02ea6d5cfe042928a3565d1.tar.bz2
upstream-77645ffcd9ad767be02ea6d5cfe042928a3565d1.zip
ramips: add support for the GnuBee Personal Cloud One
The GnuBee Personal Cloud One crowdfunded on https://www.crowdsupply.com It is a low-cost, low-power, network-attached storage device. Specifications: - SoC: MediaTek MT7621AT - RAM: DDR3 512 MB - Flash: 32 MB - Six SATA ports for 2.5" Drives - One micro SDcard - One USB 3.0 - Two USB 2.0 - Gigabit Ethernet: 1 x WAN and 1 x LAN - UART 3.5mm Audio Jack or 3 pin header - 57600 8N1 - Four GPIOs available on a pin header Flash instructions: The GnuBee Personal Cloud One ships with libreCMC installed. libreCMC is a Free Software Foundation approved fork of LEDE/OpenWrt. As such one can upgrade using the webinterface or sysupgrade. Das U-Boot has multiple options for recovery or updates including : - USB - http - tftp Signed-off-by: L. D. Pinney <ldpinney@gmail.com> [use switchdev led trigger, all interfaces are in vlan1; rename leds according to board.d setting; remove ge2 group from the pinmux, this group doesn't exist in the driver] Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/mt7621.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index bf0e292286..a67facb83b 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -75,6 +75,14 @@ define Device/firewrt
endef
TARGET_DEVICES += firewrt
+define Device/gb-pc1
+ DTS := GB-PC1
+ DEVICE_TITLE := GnuBee Personal Cloud One
+ DEVICE_PACKAGES := kmod-ata-core kmod-ata-ahci kmod-usb3 kmod-sdhci-mt7620
+ IMAGE_SIZE := $(ralink_default_fw_size_32M)
+endef
+TARGET_DEVICES += gb-pc1
+
define Device/hc5962
DTS := HC5962
BLOCKSIZE := 128k