aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorAlexander Couzens <lynxis@fe80.eu>2021-06-01 21:09:26 +0000
committerAlexander Couzens <lynxis@fe80.eu>2021-07-05 17:27:13 +0200
commit8d497b65704f62294a4bbc0e1f5aa4eb1dbf9e24 (patch)
treec446dca5ab183ee082a3bd9e52d027baf34c745c /target/linux/ramips/image
parentbb2a9af6f1f3a03617002d0b9ba361f97d68dc02 (diff)
downloadupstream-8d497b65704f62294a4bbc0e1f5aa4eb1dbf9e24.tar.gz
upstream-8d497b65704f62294a4bbc0e1f5aa4eb1dbf9e24.tar.bz2
upstream-8d497b65704f62294a4bbc0e1f5aa4eb1dbf9e24.zip
ramips: add support for minew g1-c
The minew g1-c is a smart home gateway / BLE gateway. A Nordic nRF52832 is available via USB UART (cp210x) to support BLE. The LED ring is a ring of 24x ws2812b connect to a generic GPIO (unsupported). There is a small LED which is only visible when the device is open which will be used as LED until the ws2812b is supported. The board has also a micro sdcard/tfcard slot (untested). The Nordic nRF52832 exposes SWD over a 5pin header (GND, VCC, SWD, SWC, RST). The vendor uses an older OpenWrt version, sysupgrade can be used via serial or ssh. CPU: MT7628AN / 580MHz RAM: DDR2 128 MiB RAM Flash: SPI NOR 16 MiB W25Q128 Ethernet: 1x 100 mbit (Port 0) (PoE in) USB: USB hub, 2x external, 1x internal to USB UART Power: via micro usb or PoE 802.11af UART: 3.3V, 115200 8n1 Signed-off-by: Alexander Couzens <lynxis@fe80.eu>
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/mt76x8.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt76x8.mk b/target/linux/ramips/image/mt76x8.mk
index 3ba4d658be..3f738fc488 100644
--- a/target/linux/ramips/image/mt76x8.mk
+++ b/target/linux/ramips/image/mt76x8.mk
@@ -269,6 +269,14 @@ define Device/mercury_mac1200r-v2
endef
TARGET_DEVICES += mercury_mac1200r-v2
+define Device/minew_g1-c
+ IMAGE_SIZE := 15744k
+ DEVICE_VENDOR := Minew
+ DEVICE_MODEL := G1-C
+ DEVICE_PACKAGES := kmod-usb2 kmod-usb-ohci kmod-usb-ledtrig-usbport kmod-usb-serial-cp210x
+endef
+TARGET_DEVICES += minew_g1-c
+
define Device/netgear_r6020
$(Device/netgear_sercomm_nor)
IMAGE_SIZE := 7104k