aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/patches-5.4/0048-asoc-add-mt7620-support.patch
diff options
context:
space:
mode:
authorDENG Qingfang <dengqf6@mail2.sysu.edu.cn>2020-03-01 17:06:45 +0800
committerChuanhong Guo <gch981213@gmail.com>2020-04-04 12:04:13 +0800
commit6be0da90a165912da7bd56e7bd4d7b2d978b4706 (patch)
tree00d4d9ccd7a62bfb84a0b27819c6c2145f759af1 /target/linux/ramips/patches-5.4/0048-asoc-add-mt7620-support.patch
parentd75c9b8f81b1a4f65132a5fed81f0a3fbbbd8fee (diff)
downloadupstream-6be0da90a165912da7bd56e7bd4d7b2d978b4706.tar.gz
upstream-6be0da90a165912da7bd56e7bd4d7b2d978b4706.tar.bz2
upstream-6be0da90a165912da7bd56e7bd4d7b2d978b4706.zip
ramips: refresh patches
Removed upstreamed/solved elsewhere upstream: - 0001-MIPS-ralink-Add-rt3352-SPI_CS1-pinmux.patch - 0002-MIPS-pci-rt2880-set-pci-controller-of_node.patch - 0004-MIPS-ralink-add-MT7621-pcie-driver.patch - 0009-PCI-MIPS-enable-PCIe-on-MT7688.patch - 0025-pinctrl-ralink-add-pinctrl-driver.patch - 0028-GPIO-ralink-add-mt7621-gpio-controller.patch - 0043-spi-add-mt7621-support.patch - 0045-i2c-add-mt7621-driver.patch - 0047-DMA-ralink-add-rt2880-dma-engine.patch - 0053-mtd-spi-nor-add-w25q256-3b-mode-switch.patch - 0054-mtd-spi-nor-w25q256-respect-default-mode.patch - 0099-pci-mt7620.patch - 304-spi-nor-enable-4B-opcodes-for-mx25l25635f.patch Removed because of the new NAND driver: - 0038-Revert-mtd-nand-Remove-unused-chip-write_page-hook.patch - 0039-mtd-add-mt7621-nand-support.patch - 0040-nand-hack.patch Remove patch that no longer applies (needs rework): - 0034-NET-multi-phy-support.patch Signed-off-by: DENG Qingfang <dengqf6@mail2.sysu.edu.cn>
Diffstat (limited to 'target/linux/ramips/patches-5.4/0048-asoc-add-mt7620-support.patch')
-rw-r--r--target/linux/ramips/patches-5.4/0048-asoc-add-mt7620-support.patch10
1 files changed, 5 insertions, 5 deletions
diff --git a/target/linux/ramips/patches-5.4/0048-asoc-add-mt7620-support.patch b/target/linux/ramips/patches-5.4/0048-asoc-add-mt7620-support.patch
index 1834e88538..d0d4141a8d 100644
--- a/target/linux/ramips/patches-5.4/0048-asoc-add-mt7620-support.patch
+++ b/target/linux/ramips/patches-5.4/0048-asoc-add-mt7620-support.patch
@@ -20,15 +20,15 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
--- a/arch/mips/ralink/of.c
+++ b/arch/mips/ralink/of.c
-@@ -15,6 +15,7 @@
+@@ -13,6 +13,7 @@
#include <linux/of_fdt.h>
#include <linux/kernel.h>
- #include <linux/bootmem.h>
+ #include <linux/memblock.h>
+#include <linux/module.h>
#include <linux/of_platform.h>
#include <linux/of_address.h>
-@@ -26,6 +27,7 @@
+@@ -24,6 +25,7 @@
#include "common.h"
__iomem void *rt_sysc_membase;
@@ -38,7 +38,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
__iomem void *plat_of_remap_node(const char *node)
--- a/sound/soc/Kconfig
+++ b/sound/soc/Kconfig
-@@ -59,6 +59,7 @@ source "sound/soc/mxs/Kconfig"
+@@ -60,6 +60,7 @@ source "sound/soc/mxs/Kconfig"
source "sound/soc/pxa/Kconfig"
source "sound/soc/qcom/Kconfig"
source "sound/soc/rockchip/Kconfig"
@@ -48,7 +48,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
source "sound/soc/sirf/Kconfig"
--- a/sound/soc/Makefile
+++ b/sound/soc/Makefile
-@@ -40,6 +40,7 @@ obj-$(CONFIG_SND_SOC) += kirkwood/
+@@ -43,6 +43,7 @@ obj-$(CONFIG_SND_SOC) += kirkwood/
obj-$(CONFIG_SND_SOC) += pxa/
obj-$(CONFIG_SND_SOC) += qcom/
obj-$(CONFIG_SND_SOC) += rockchip/