aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips
diff options
context:
space:
mode:
authorINAGAKI Hiroshi <musashino.open@gmail.com>2020-04-26 12:24:33 +0900
committerDavid Bauer <mail@david-bauer.net>2020-04-27 12:22:02 +0200
commitc998ae7f0e9bd51be4935055efbc3834a92698b1 (patch)
tree9f22e0bd462317222d45863cab0efda75065ddea /target/linux/ramips
parenta25bb8610ffb985feb49652ce633a60182a0bd5c (diff)
downloadupstream-c998ae7f0e9bd51be4935055efbc3834a92698b1.tar.gz
upstream-c998ae7f0e9bd51be4935055efbc3834a92698b1.tar.bz2
upstream-c998ae7f0e9bd51be4935055efbc3834a92698b1.zip
ramips: use lzma-loader for I-O DATA mt7621 devices
The official sysupgrade images for I-O DATA devices manufactured by MSTC (MitraStar Technology Corp.) cannot be booted normally and the kernel panics after switching to kernel 5.4. This commit fixes the issue by using lzma-loader. Note: These devices use Z-LOADER to read the kernel from NAND flash and boot it. Z-LOADER cannot load and start plain lzma-loader, so additional lzma-compression is needed. Signed-off-by: INAGAKI Hiroshi <musashino.open@gmail.com> Co-developed-by: Yanase Yuki <dev@zpc.sakura.ne.jp> Signed-off-by: Yanase Yuki <dev@zpc.sakura.ne.jp> Tested-by: Yanase Yuki <dev@zpc.sakura.ne.jp> [wn-ax2033gr]
Diffstat (limited to 'target/linux/ramips')
-rw-r--r--target/linux/ramips/image/mt7621.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index abaf3efe2b..101e5bbba6 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -379,6 +379,8 @@ define Device/iodata_wn-ax1167gr2
IMAGE_SIZE := 51200k
DEVICE_VENDOR := I-O DATA
DEVICE_MODEL := WN-AX1167GR2
+ LOADER_TYPE := bin
+ KERNEL := kernel-bin | append-dtb | lzma | loader-kernel | lzma | uImage lzma
KERNEL_INITRAMFS := $(KERNEL_DTB) | custom-initramfs-uimage 3.10(XBC.1)b10 | \
iodata-mstc-header
IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
@@ -395,6 +397,8 @@ define Device/iodata_wn-ax2033gr
IMAGE_SIZE := 51200k
DEVICE_VENDOR := I-O DATA
DEVICE_MODEL := WN-AX2033GR
+ LOADER_TYPE := bin
+ KERNEL := kernel-bin | append-dtb | lzma | loader-kernel | lzma | uImage lzma
KERNEL_INITRAMFS := $(KERNEL_DTB) | custom-initramfs-uimage 3.10(VST.1)C10 | \
iodata-mstc-header
IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
@@ -411,6 +415,8 @@ define Device/iodata_wn-dx1167r
IMAGE_SIZE := 51200k
DEVICE_VENDOR := I-O DATA
DEVICE_MODEL := WN-DX1167R
+ LOADER_TYPE := bin
+ KERNEL := kernel-bin | append-dtb | lzma | loader-kernel | lzma | uImage lzma
KERNEL_INITRAMFS := $(KERNEL_DTB) | custom-initramfs-uimage 3.10(XIK.1)b10 | \
iodata-mstc-header
IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata