aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/rdc-2.6
diff options
context:
space:
mode:
authorTim Yardley <lst@openwrt.org>2007-03-02 23:02:38 +0000
committerTim Yardley <lst@openwrt.org>2007-03-02 23:02:38 +0000
commit03beb39e5f76f6361adc99244afb4d274310d158 (patch)
treead51f5b31163969f63c468720c0ac606bf0fe17e /target/linux/rdc-2.6
parentfa859ea32a7d0775e426b80757b37c09e3e2282c (diff)
downloadupstream-03beb39e5f76f6361adc99244afb4d274310d158.tar.gz
upstream-03beb39e5f76f6361adc99244afb4d274310d158.tar.bz2
upstream-03beb39e5f76f6361adc99244afb4d274310d158.zip
split out profile definitions from Makefiles
structure is as follows: target/linux/<arch>/profiles/<profilename>.mk These files are included by a blob match in the target Makefile The files should be labeled based on their profile Name in the definition SVN-Revision: 6468
Diffstat (limited to 'target/linux/rdc-2.6')
-rw-r--r--target/linux/rdc-2.6/Makefile7
-rw-r--r--target/linux/rdc-2.6/profiles/Ralink.mk13
2 files changed, 15 insertions, 5 deletions
diff --git a/target/linux/rdc-2.6/Makefile b/target/linux/rdc-2.6/Makefile
index f1f751eee6..306734b273 100644
--- a/target/linux/rdc-2.6/Makefile
+++ b/target/linux/rdc-2.6/Makefile
@@ -18,10 +18,7 @@ endef
include $(INCLUDE_DIR)/kernel-build.mk
-define Profile/Ralink
- NAME:=Ralink WiFi (default)
- PACKAGES:=kmod-rt61
-endef
-$(eval $(call Profile,Ralink))
+# include the profiles
+-include profiles/*.mk
$(eval $(call BuildKernel))
diff --git a/target/linux/rdc-2.6/profiles/Ralink.mk b/target/linux/rdc-2.6/profiles/Ralink.mk
new file mode 100644
index 0000000000..f4c435ddca
--- /dev/null
+++ b/target/linux/rdc-2.6/profiles/Ralink.mk
@@ -0,0 +1,13 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Ralink
+ NAME:=Ralink WiFi
+ PACKAGES:=kmod-rt61
+endef
+$(eval $(call Profile,Ralink))
+