aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/realtek/patches-5.10/302-clocksource-add-rtl9300-driver.patch
diff options
context:
space:
mode:
authorINAGAKI Hiroshi <musashino.open@gmail.com>2021-05-05 09:32:27 +0900
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2021-09-26 00:32:17 +0200
commit95170b4350ec6dcadd4dc740c130709c46aa6ecb (patch)
tree3280bba44b875daf116b57a3d27f8f13bab8c47c /target/linux/realtek/patches-5.10/302-clocksource-add-rtl9300-driver.patch
parent1edc7078d6549a7ff39d62318d2879ee72bd0b9d (diff)
downloadupstream-95170b4350ec6dcadd4dc740c130709c46aa6ecb.tar.gz
upstream-95170b4350ec6dcadd4dc740c130709c46aa6ecb.tar.bz2
upstream-95170b4350ec6dcadd4dc740c130709c46aa6ecb.zip
realtek: copy config/files/patches to 5.10
this patch copies the following files from 5.4 to 5.10: - config-5.4 -> config-5.10 - files-5.4/ -> files-5.10/ - patches-5.4/ -> patches-5.10/ Signed-off-by: INAGAKI Hiroshi <musashino.open@gmail.com> [rebase on change in files-5.4] Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/realtek/patches-5.10/302-clocksource-add-rtl9300-driver.patch')
-rw-r--r--target/linux/realtek/patches-5.10/302-clocksource-add-rtl9300-driver.patch34
1 files changed, 34 insertions, 0 deletions
diff --git a/target/linux/realtek/patches-5.10/302-clocksource-add-rtl9300-driver.patch b/target/linux/realtek/patches-5.10/302-clocksource-add-rtl9300-driver.patch
new file mode 100644
index 0000000000..1c41db75b2
--- /dev/null
+++ b/target/linux/realtek/patches-5.10/302-clocksource-add-rtl9300-driver.patch
@@ -0,0 +1,34 @@
+--- a/drivers/clocksource/Kconfig
++++ b/drivers/clocksource/Kconfig
+@@ -127,6 +127,15 @@ config RDA_TIMER
+ help
+ Enables the support for the RDA Micro timer driver.
+
++config RTL9300_TIMER
++ bool "Clocksource/timer for the Realtek RTL9300 family of SoCs"
++ depends on MIPS
++ select COMMON_CLK
++ select TIMER_OF
++ select CLKSRC_MMIO
++ help
++ Enables support for the Realtek RTL9300 timer driver.
++
+ config SUN4I_TIMER
+ bool "Sun4i timer driver" if COMPILE_TEST
+ depends on HAS_IOMEM
+@@ -696,5 +705,4 @@ config INGENIC_TIMER
+ select IRQ_DOMAIN
+ help
+ Support for the timer/counter unit of the Ingenic JZ SoCs.
+-
+ endmenu
+--- a/drivers/clocksource/Makefile
++++ b/drivers/clocksource/Makefile
+@@ -61,6 +61,7 @@ obj-$(CONFIG_MILBEAUT_TIMER) += timer-mi
+ obj-$(CONFIG_SPRD_TIMER) += timer-sprd.o
+ obj-$(CONFIG_NPCM7XX_TIMER) += timer-npcm7xx.o
+ obj-$(CONFIG_RDA_TIMER) += timer-rda.o
++obj-$(CONFIG_RTL9300_TIMER) += timer-rtl9300.o
+
+ obj-$(CONFIG_ARC_TIMERS) += arc_timer.o
+ obj-$(CONFIG_ARM_ARCH_TIMER) += arm_arch_timer.o