aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/rtl838x/image
diff options
context:
space:
mode:
authorJohn Crispin <john@phrozen.org>2020-10-15 13:36:10 +0200
committerJohn Crispin <john@phrozen.org>2020-10-15 13:36:10 +0200
commit479d1154c4eb859e4412c41f221db0df071a09d0 (patch)
tree904b4e06bda2cbadf964e579f8a35949f6a45d64 /target/linux/rtl838x/image
parent076fdd9fec874581dc3059c34ca72be6aab3d81d (diff)
downloadupstream-479d1154c4eb859e4412c41f221db0df071a09d0.tar.gz
upstream-479d1154c4eb859e4412c41f221db0df071a09d0.tar.bz2
upstream-479d1154c4eb859e4412c41f221db0df071a09d0.zip
rtl838x: add DLink DGS-1210-16 support
Signed-off-by: John Crispin <john@phrozen.org>
Diffstat (limited to 'target/linux/rtl838x/image')
-rw-r--r--target/linux/rtl838x/image/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/target/linux/rtl838x/image/Makefile b/target/linux/rtl838x/image/Makefile
index eef1fe0a33..291888ab2d 100644
--- a/target/linux/rtl838x/image/Makefile
+++ b/target/linux/rtl838x/image/Makefile
@@ -41,4 +41,13 @@ define Device/allnet_all-sg8208m
endef
TARGET_DEVICES += allnet_all-sg8208m
+define Device/d-link_dgs-1210-16
+ SOC := rtl8382
+ IMAGE_SIZE := 13824k
+ DEVICE_VENDOR := D-Link
+ DEVICE_MODEL := DGS-1210-16
+ DEVICE_PACKAGES := ip-full ip-bridge ethtool tc
+endef
+TARGET_DEVICES += d-link_dgs-1210-16
+
$(eval $(call BuildImage))