aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/rtl838x/image
diff options
context:
space:
mode:
authorJohn Crispin <john@phrozen.org>2020-10-19 14:47:45 +0200
committerJohn Crispin <john@phrozen.org>2020-10-19 14:53:27 +0200
commitc78e123d5a5e7c3baa74f326613a14f7e99a29a3 (patch)
treee7d9504aa5c775700eeb278a832913e41274377a /target/linux/rtl838x/image
parent7f5f738466aca2cd8f5daf73f68f4d32b70d43b5 (diff)
downloadupstream-c78e123d5a5e7c3baa74f326613a14f7e99a29a3.tar.gz
upstream-c78e123d5a5e7c3baa74f326613a14f7e99a29a3.tar.bz2
upstream-c78e123d5a5e7c3baa74f326613a14f7e99a29a3.zip
rtl838x: various fixes
* add d-link_dgs-1210-10p support * make sure mips16 is disabled * add a generic sub target * add proper cflags Signed-off-by: John Crispin <john@phrozen.org>
Diffstat (limited to 'target/linux/rtl838x/image')
-rw-r--r--target/linux/rtl838x/image/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/target/linux/rtl838x/image/Makefile b/target/linux/rtl838x/image/Makefile
index 291888ab2d..f490fa7ffe 100644
--- a/target/linux/rtl838x/image/Makefile
+++ b/target/linux/rtl838x/image/Makefile
@@ -50,4 +50,13 @@ define Device/d-link_dgs-1210-16
endef
TARGET_DEVICES += d-link_dgs-1210-16
+define Device/d-link_dgs-1210-10p
+ SOC := rtl8382
+ IMAGE_SIZE := 13824k
+ DEVICE_VENDOR := D-Link
+ DEVICE_MODEL := DGS-1210-10P
+ DEVICE_PACKAGES := ip-full ip-bridge ethtool tc lua-rs232
+endef
+TARGET_DEVICES += d-link_dgs-1210-10p
+
$(eval $(call BuildImage))