aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/sunxi/image/Makefile
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2019-12-06 00:47:18 +0100
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2019-12-13 12:19:51 +0100
commit3a4ad758f537bd4cc24163f76d2865179484541c (patch)
treefbfe4f4cf2c30fda3aa591517a7bc9ba0e727505 /target/linux/sunxi/image/Makefile
parenta4cdb537b17ede9785ddbaef5ed9d69f3ab89052 (diff)
downloadupstream-3a4ad758f537bd4cc24163f76d2865179484541c.tar.gz
upstream-3a4ad758f537bd4cc24163f76d2865179484541c.tar.bz2
upstream-3a4ad758f537bd4cc24163f76d2865179484541c.zip
sunxi: construct DTS name from device node name and SOC
The device part in the SUNXI_DTS variable always corresponds to device node name. This is another redundancy that can be removed by calculating the DTS name from a newly introduced SUNXI_SOC variable and the node name. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/sunxi/image/Makefile')
-rw-r--r--target/linux/sunxi/image/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/target/linux/sunxi/image/Makefile b/target/linux/sunxi/image/Makefile
index 04e0abee49..929f4c70f9 100644
--- a/target/linux/sunxi/image/Makefile
+++ b/target/linux/sunxi/image/Makefile
@@ -32,12 +32,15 @@ endef
# why \x00\x00\x00\x00 for zImage-initramfs
define Device/Default
PROFILES := Default
- DEVICE_VARS := SUNXI_DTS SUNXI_UBOOT
+ DEVICE_VARS := SUNXI_SOC SUNXI_DTS SUNXI_DTS_DIR SUNXI_UBOOT
KERNEL_NAME := zImage
KERNEL := kernel-bin | uImage none
IMAGES := sdcard.img.gz
IMAGE/sdcard.img.gz := sunxi-sdcard | append-metadata | gzip
SUPPORTED_DEVICES := $(subst _,$(comma),$(1))
+ SUNXI_SOC :=
+ SUNXI_DTS_DIR :=
+ SUNXI_DTS = $$(SUNXI_DTS_DIR)$$(SUNXI_SOC)-$(lastword $(subst _, ,$(1)))
endef
include cortex-a7.mk