aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/sunxi/image
diff options
context:
space:
mode:
authorZoltan HERPAI <wigyori@uid0.hu>2020-04-24 09:58:53 +0200
committerZoltan HERPAI <wigyori@uid0.hu>2021-04-11 23:14:55 +0200
commit3225241c2bc61e907ea2980cd2f14ea6589cdf2d (patch)
treeba2c6a1e637ac8a24c3f03449157b314a290c342 /target/linux/sunxi/image
parentc2163530db3c95745c822e4a573a220ba9f98ca7 (diff)
downloadupstream-3225241c2bc61e907ea2980cd2f14ea6589cdf2d.tar.gz
upstream-3225241c2bc61e907ea2980cd2f14ea6589cdf2d.tar.bz2
upstream-3225241c2bc61e907ea2980cd2f14ea6589cdf2d.zip
sunxi: add support for H6 boards and OrangePiOnePlus
Specifications: SoC Allwinner H6 @ 1.8 Ghz DRAM 1Gb LPDDR3 Power DC 5V @ 3A Video HDMI (Type 2.0A - full) Audio HDMI, on-board microphone Network 10/100/1000Mbps Ethernet (Realtek RTL8211) Storage microSD USB 1 USB2.0 Host, 1 USB2.0 OTG Debug Serial UART Flashing instructions: Standard sunxi SD card installation procedure - copy image to SD card, insert into SD card slot on the device and boot. Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu>
Diffstat (limited to 'target/linux/sunxi/image')
-rw-r--r--target/linux/sunxi/image/cortexa53.mk17
1 files changed, 15 insertions, 2 deletions
diff --git a/target/linux/sunxi/image/cortexa53.mk b/target/linux/sunxi/image/cortexa53.mk
index fe561d0923..2d18b0b227 100644
--- a/target/linux/sunxi/image/cortexa53.mk
+++ b/target/linux/sunxi/image/cortexa53.mk
@@ -9,13 +9,18 @@ define Device/sun50i
KERNEL := kernel-bin
endef
+define Device/sun50i-a64
+ SOC := sun50i-a64
+ $(Device/sun50i)
+endef
+
define Device/sun50i-h5
SOC := sun50i-h5
$(Device/sun50i)
endef
-define Device/sun50i-a64
- SOC := sun50i-a64
+define Device/sun50i-h6
+ SOC := sun50i-h6
$(Device/sun50i)
endef
@@ -79,6 +84,14 @@ define Device/pine64_sopine-baseboard
endef
TARGET_DEVICES += pine64_sopine-baseboard
+define Device/xunlong_orangepi-one-plus
+ $(Device/sun50i-h6)
+ DEVICE_VENDOR := Xunlong
+ DEVICE_MODEL := Orange Pi One Plus
+ SUNXI_DTS_DIR := allwinner/
+endef
+TARGET_DEVICES += xunlong_orangepi-one-plus
+
define Device/xunlong_orangepi-pc2
DEVICE_VENDOR := Xunlong
DEVICE_MODEL := Orange Pi PC 2