aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/sunxi/image
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2018-01-27 23:46:50 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2018-02-17 01:15:25 +0100
commit6be73c07dbd69d49493d69bbd7978ec3d89bef56 (patch)
tree889f97cfdefe1b6e99d8b7cfcfbc3c671492ba3e /target/linux/sunxi/image
parent718e5cd1cf08d7e31e3b93a03c92b90643ccc905 (diff)
downloadupstream-6be73c07dbd69d49493d69bbd7978ec3d89bef56.tar.gz
upstream-6be73c07dbd69d49493d69bbd7978ec3d89bef56.tar.bz2
upstream-6be73c07dbd69d49493d69bbd7978ec3d89bef56.zip
sunxi: Add Xunlong Orange Pi Zero Plus
This is based on a patch from armbian: https://github.com/armbian/build/blob/master/patch/kernel/sunxi-next/sunxi-add-orangepi-zero-plus.patch Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Diffstat (limited to 'target/linux/sunxi/image')
-rw-r--r--target/linux/sunxi/image/cortex-a53.mk11
1 files changed, 11 insertions, 0 deletions
diff --git a/target/linux/sunxi/image/cortex-a53.mk b/target/linux/sunxi/image/cortex-a53.mk
index eb31aa8d4c..cd103d47d0 100644
--- a/target/linux/sunxi/image/cortex-a53.mk
+++ b/target/linux/sunxi/image/cortex-a53.mk
@@ -27,4 +27,15 @@ endef
TARGET_DEVICES += sun50i-a64-pine64-plus
+
+define Device/sun50i-h5-orangepi-zero-plus
+ DEVICE_TITLE:=Xunlong Orange Pi Zero Plus
+ SUPPORTED_DEVICES:=xunlong,orangepi-zero-plus
+ SUNXI_DTS:=allwinner/sun50i-h5-orangepi-zero-plus
+ KERNEL_NAME := Image
+ KERNEL := kernel-bin
+endef
+
+TARGET_DEVICES += sun50i-h5-orangepi-zero-plus
+
endif