aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/sunxi/image
diff options
context:
space:
mode:
authorFan Fan <fkpwolf@gmail.com>2018-03-19 17:52:46 +0800
committerHauke Mehrtens <hauke@hauke-m.de>2018-03-23 23:53:20 +0100
commit8e1065d681daff321f715ce5c6c172c12036bd6f (patch)
tree535ae2f44ed97a37bac9026341b7984058515cf8 /target/linux/sunxi/image
parent43788a91fb61bdf869e2ca68841ae34e422961d6 (diff)
downloadupstream-8e1065d681daff321f715ce5c6c172c12036bd6f.tar.gz
upstream-8e1065d681daff321f715ce5c6c172c12036bd6f.tar.bz2
upstream-8e1065d681daff321f715ce5c6c172c12036bd6f.zip
sunxi: add build for sopine
This will generate image for Pine64 Sopine board. Signed-off-by: Fan Fan <fkpwolf@gmail.com>
Diffstat (limited to 'target/linux/sunxi/image')
-rw-r--r--target/linux/sunxi/image/cortex-a53.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/target/linux/sunxi/image/cortex-a53.mk b/target/linux/sunxi/image/cortex-a53.mk
index cd103d47d0..344071b94d 100644
--- a/target/linux/sunxi/image/cortex-a53.mk
+++ b/target/linux/sunxi/image/cortex-a53.mk
@@ -27,6 +27,16 @@ endef
TARGET_DEVICES += sun50i-a64-pine64-plus
+define Device/sun50i-a64-sopine-baseboard
+ DEVICE_TITLE:=Pine64 Sopine
+ SUPPORTED_DEVICES:=pine64,sopine-baseboard
+ SUNXI_DTS:=allwinner/sun50i-a64-sopine-baseboard
+ KERNEL_NAME := Image
+ KERNEL := kernel-bin
+endef
+
+TARGET_DEVICES += sun50i-a64-sopine-baseboard
+
define Device/sun50i-h5-orangepi-zero-plus
DEVICE_TITLE:=Xunlong Orange Pi Zero Plus