aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/tegra/image/Makefile
diff options
context:
space:
mode:
authorTomasz Maciej Nowak <tomek_n@o2.pl>2019-04-01 19:25:41 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2019-04-06 14:48:46 +0200
commit1b3dda179a6b2ec819aa3f863662c6f00f89c961 (patch)
tree4d20c71d568d3ef498aceccff8bda921e0147ce1 /target/linux/tegra/image/Makefile
parentb8744376445692062c7d4e59a9814dc70c76a88d (diff)
downloadupstream-1b3dda179a6b2ec819aa3f863662c6f00f89c961.tar.gz
upstream-1b3dda179a6b2ec819aa3f863662c6f00f89c961.tar.bz2
upstream-1b3dda179a6b2ec819aa3f863662c6f00f89c961.zip
uboot-tegra: add U-Boot for tegra boards
Add U-Boot for NVIDIA Tegra based boards, with the first being CompuLab TrimSlice. This is part of initial support for this board. Signed-off-by: Tomasz Maciej Nowak <tomek_n@o2.pl>
Diffstat (limited to 'target/linux/tegra/image/Makefile')
-rw-r--r--target/linux/tegra/image/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/target/linux/tegra/image/Makefile b/target/linux/tegra/image/Makefile
index 757e5b823f..5e3427ad27 100644
--- a/target/linux/tegra/image/Makefile
+++ b/target/linux/tegra/image/Makefile
@@ -32,9 +32,11 @@ define Build/tegra-sdcard
$(CONFIG_TARGET_KERNEL_PARTSIZE) $@.boot \
$(CONFIG_TARGET_ROOTFS_PARTSIZE) $(IMAGE_ROOTFS) \
2048
+
+ $(if $(UBOOT),dd if=$(STAGING_DIR_IMAGE)/$(UBOOT).img of=$@ bs=512 skip=1 seek=1 conv=notrunc)
endef
-DEVICE_VARS += BOOT_SCRIPT
+DEVICE_VARS += BOOT_SCRIPT UBOOT
define Device/Default
BOOT_SCRIPT := generic-bootscript
IMAGES := sdcard.img.gz