aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/tegra/patches-5.4
diff options
context:
space:
mode:
authorTomasz Maciej Nowak <tomek_n@o2.pl>2020-03-16 19:32:09 +0100
committerPetr Štetiar <ynezz@true.cz>2020-03-17 00:51:48 +0100
commitd42abe544e4c3fe81c0d11da24aeae49479b0a8c (patch)
tree2a005ac0f153eb8e90e56f39829a999835021aa1 /target/linux/tegra/patches-5.4
parent86c939841c045c14f81c078dcd6c62682b5a30b1 (diff)
downloadupstream-d42abe544e4c3fe81c0d11da24aeae49479b0a8c.tar.gz
upstream-d42abe544e4c3fe81c0d11da24aeae49479b0a8c.tar.bz2
upstream-d42abe544e4c3fe81c0d11da24aeae49479b0a8c.zip
tegra: refresh patches and kernel config for 5.4
This commit also disables Trusted Foundations firmware support as this feature won't be used by any device. Signed-off-by: Tomasz Maciej Nowak <tomek_n@o2.pl> [fix merge conflict in tegra/Makefile] Signed-off-by: Petr Štetiar <ynezz@true.cz>
Diffstat (limited to 'target/linux/tegra/patches-5.4')
-rw-r--r--target/linux/tegra/patches-5.4/100-serial8250-on-tegra-hsuart-recover-from-spurious-interrupts-due-to-tegra2-silicon-bug.patch6
1 files changed, 3 insertions, 3 deletions
diff --git a/target/linux/tegra/patches-5.4/100-serial8250-on-tegra-hsuart-recover-from-spurious-interrupts-due-to-tegra2-silicon-bug.patch b/target/linux/tegra/patches-5.4/100-serial8250-on-tegra-hsuart-recover-from-spurious-interrupts-due-to-tegra2-silicon-bug.patch
index 9e8c331934..08ed9d441c 100644
--- a/target/linux/tegra/patches-5.4/100-serial8250-on-tegra-hsuart-recover-from-spurious-interrupts-due-to-tegra2-silicon-bug.patch
+++ b/target/linux/tegra/patches-5.4/100-serial8250-on-tegra-hsuart-recover-from-spurious-interrupts-due-to-tegra2-silicon-bug.patch
@@ -36,10 +36,10 @@ David
--- a/drivers/tty/serial/8250/8250_core.c
+++ b/drivers/tty/serial/8250/8250_core.c
-@@ -136,6 +136,38 @@ static irqreturn_t serial8250_interrupt(
- "serial8250: too much work for irq%d\n", irq);
+@@ -133,6 +133,38 @@ static irqreturn_t serial8250_interrupt(
+
+ if (l == i->head && pass_counter++ > PASS_LIMIT)
break;
- }
+
+#ifdef CONFIG_ARCH_TEGRA_2x_SOC
+ if (!handled && (port->type == PORT_TEGRA)) {