aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/uml/patches-2.6.39/001-gcc4_unit_at_a_time_i386_fix.patch
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2011-06-04 18:26:54 +0000
committerFlorian Fainelli <florian@openwrt.org>2011-06-04 18:26:54 +0000
commit89dd8aed1f99cb1d9b62793b90030e9bcc77d080 (patch)
tree5b3a3675c70cd18a6da31caa56db05829b18ade4 /target/linux/uml/patches-2.6.39/001-gcc4_unit_at_a_time_i386_fix.patch
parentee877c8ba30e7996fdf71c3b502554f547e2c81e (diff)
downloadupstream-89dd8aed1f99cb1d9b62793b90030e9bcc77d080.tar.gz
upstream-89dd8aed1f99cb1d9b62793b90030e9bcc77d080.tar.bz2
upstream-89dd8aed1f99cb1d9b62793b90030e9bcc77d080.zip
update to 2.6.39.1
SVN-Revision: 27110
Diffstat (limited to 'target/linux/uml/patches-2.6.39/001-gcc4_unit_at_a_time_i386_fix.patch')
-rw-r--r--target/linux/uml/patches-2.6.39/001-gcc4_unit_at_a_time_i386_fix.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/target/linux/uml/patches-2.6.39/001-gcc4_unit_at_a_time_i386_fix.patch b/target/linux/uml/patches-2.6.39/001-gcc4_unit_at_a_time_i386_fix.patch
new file mode 100644
index 0000000000..442c0ec76e
--- /dev/null
+++ b/target/linux/uml/patches-2.6.39/001-gcc4_unit_at_a_time_i386_fix.patch
@@ -0,0 +1,11 @@
+--- a/arch/um/Makefile-i386
++++ b/arch/um/Makefile-i386
+@@ -35,7 +35,7 @@ cflags-y += -ffreestanding
+ # Disable unit-at-a-time mode on pre-gcc-4.0 compilers, it makes gcc use
+ # a lot more stack due to the lack of sharing of stacklots. Also, gcc
+ # 4.3.0 needs -funit-at-a-time for extern inline functions.
+-KBUILD_CFLAGS += $(shell if [ $(call cc-version) -lt 0400 ] ; then \
++KBUILD_CFLAGS += $(shell if [ $(call cc-version) -lt 0403 ] ; then \
+ echo $(call cc-option,-fno-unit-at-a-time); \
+ else echo $(call cc-option,-funit-at-a-time); fi ;)
+