aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/uml/patches-2.6.39/002-gcc4_unfortify_source.patch
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2011-06-04 18:26:54 +0000
committerFlorian Fainelli <florian@openwrt.org>2011-06-04 18:26:54 +0000
commit89dd8aed1f99cb1d9b62793b90030e9bcc77d080 (patch)
tree5b3a3675c70cd18a6da31caa56db05829b18ade4 /target/linux/uml/patches-2.6.39/002-gcc4_unfortify_source.patch
parentee877c8ba30e7996fdf71c3b502554f547e2c81e (diff)
downloadupstream-89dd8aed1f99cb1d9b62793b90030e9bcc77d080.tar.gz
upstream-89dd8aed1f99cb1d9b62793b90030e9bcc77d080.tar.bz2
upstream-89dd8aed1f99cb1d9b62793b90030e9bcc77d080.zip
update to 2.6.39.1
SVN-Revision: 27110
Diffstat (limited to 'target/linux/uml/patches-2.6.39/002-gcc4_unfortify_source.patch')
-rw-r--r--target/linux/uml/patches-2.6.39/002-gcc4_unfortify_source.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/target/linux/uml/patches-2.6.39/002-gcc4_unfortify_source.patch b/target/linux/uml/patches-2.6.39/002-gcc4_unfortify_source.patch
new file mode 100644
index 0000000000..2be33d02a3
--- /dev/null
+++ b/target/linux/uml/patches-2.6.39/002-gcc4_unfortify_source.patch
@@ -0,0 +1,21 @@
+--- a/arch/um/Makefile-i386
++++ b/arch/um/Makefile-i386
+@@ -39,4 +39,8 @@ KBUILD_CFLAGS += $(shell if [ $(call cc-
+ echo $(call cc-option,-fno-unit-at-a-time); \
+ else echo $(call cc-option,-funit-at-a-time); fi ;)
+
++# disable compile-time buffer checks, enabled by default on Ubuntu 8.10
++# and later
++KBUILD_CFLAGS += $(call cc-option,-U_FORTIFY_SOURCE)
++
+ KBUILD_CFLAGS += $(cflags-y)
+--- a/arch/um/Makefile-x86_64
++++ b/arch/um/Makefile-x86_64
+@@ -24,3 +24,7 @@ LINK-y += -m64
+
+ # Do unit-at-a-time unconditionally on x86_64, following the host
+ KBUILD_CFLAGS += $(call cc-option,-funit-at-a-time)
++
++# disable compile-time buffer checks, enabled by default on Ubuntu 8.10
++# and later
++KBUILD_CFLAGS += $(call cc-option,-U_FORTIFY_SOURCE)