aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/x86/image
diff options
context:
space:
mode:
authorPaul Spooren <mail@aparcar.org>2020-03-25 09:25:10 -1000
committerPetr Štetiar <ynezz@true.cz>2020-03-28 13:20:05 +0100
commit258f070d1a4fe1808b654f58f50779fd0afafa1a (patch)
tree1f757e99a3be752b69c27e987c777c7e96f7079d /target/linux/x86/image
parent6fcca31fc3c3ddaa5e085fdf643892d31f29ab93 (diff)
downloadupstream-258f070d1a4fe1808b654f58f50779fd0afafa1a.tar.gz
upstream-258f070d1a4fe1808b654f58f50779fd0afafa1a.tar.bz2
upstream-258f070d1a4fe1808b654f58f50779fd0afafa1a.zip
x86: fix missing squashfs and ext4 rootfs images
The previous rework of x86 image creation done in commit cb007a7bf619 ("x86: switch image generation to new code") removed images of separate squashfs and ext4 filesystems which are handy for example in testing under QEMU. So this patch adds back creation of those missing rootfs images for ext4 and squashfs based filesystems. Fixes: cb007a7bf619 ("x86: switch image generation to new code") Signed-off-by: Paul Spooren <mail@aparcar.org> [commit subject and description tweaks] Signed-off-by: Petr Štetiar <ynezz@true.cz>
Diffstat (limited to 'target/linux/x86/image')
-rw-r--r--target/linux/x86/image/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/target/linux/x86/image/Makefile b/target/linux/x86/image/Makefile
index c29eef9c7a..c0c5c8323a 100644
--- a/target/linux/x86/image/Makefile
+++ b/target/linux/x86/image/Makefile
@@ -99,10 +99,12 @@ define Device/Default
IMAGE/combined.img.gz := grub-config pc | combined | grub-install | gzip
IMAGE/combined.vdi := grub-config pc | combined | grub-install | qemu-image vdi
IMAGE/combined.vmdk := grub-config pc | combined | grub-install | qemu-image vmdk
+ IMAGE/rootfs.img := append-rootfs
+ IMAGE/rootfs.img.gz := append-rootfs | gzip
ifeq ($(CONFIG_TARGET_IMAGES_GZIP),y)
- IMAGES := combined.img.gz
+ IMAGES := combined.img.gz rootfs.img.gz
else
- IMAGES := combined.img
+ IMAGES := combined.img rootfs.img
endif
KERNEL := kernel-bin
KERNEL_INSTALL := 1