aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/x86/patches-3.10/011-tune_lzma_options.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-09-02 07:36:40 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-09-02 07:36:40 +0000
commit11b1887c531015a6e928ed748f72a684c382910c (patch)
treea344b55b6bfc0d5c3ac8e57df5da284d3efd69d2 /target/linux/x86/patches-3.10/011-tune_lzma_options.patch
parent0a85c59040d6e053199962fe9127cc0d2d8febc3 (diff)
downloadupstream-11b1887c531015a6e928ed748f72a684c382910c.tar.gz
upstream-11b1887c531015a6e928ed748f72a684c382910c.tar.bz2
upstream-11b1887c531015a6e928ed748f72a684c382910c.zip
x86: add support for 3.10
Add kernel configuration and patches for Linux 3.10. Taken from the 'alix2: update to LINUX_VERSION 3.10.9' patch: http://patchwork.openwrt.org/patch/3971/. Russell says in the original patch: "Initial whack at updating alix2 to a current kernel. It builds and runs without problems so far. I copied target/linux/config-3.8, target/linux/x86/alix2/config-3.8, and target/linux/patches-3.8 to their 3.10 equivalents and tweaked until it built. The patches required no changes." The current patch contains additional configuration tweaks, and the kernel patches were refreshed. Signed-off-by: Russell Senior <russell@personaltelco.net> Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 37867
Diffstat (limited to 'target/linux/x86/patches-3.10/011-tune_lzma_options.patch')
-rw-r--r--target/linux/x86/patches-3.10/011-tune_lzma_options.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/target/linux/x86/patches-3.10/011-tune_lzma_options.patch b/target/linux/x86/patches-3.10/011-tune_lzma_options.patch
new file mode 100644
index 0000000000..1421f7c8fa
--- /dev/null
+++ b/target/linux/x86/patches-3.10/011-tune_lzma_options.patch
@@ -0,0 +1,22 @@
+--- a/scripts/Makefile.lib
++++ b/scripts/Makefile.lib
+@@ -303,7 +303,7 @@ cmd_bzip2 = (cat $(filter-out FORCE,$^)
+
+ quiet_cmd_lzma = LZMA $@
+ cmd_lzma = (cat $(filter-out FORCE,$^) | \
+- lzma e -d20 -lc1 -lp2 -pb2 -eos -si -so && $(call size_append, $(filter-out FORCE,$^))) > $@ || \
++ lzma e -lc8 -eos -si -so && $(call size_append, $(filter-out FORCE,$^))) > $@ || \
+ (rm -f $@ ; false)
+
+ quiet_cmd_lzo = LZO $@
+--- a/arch/x86/include/asm/boot.h
++++ b/arch/x86/include/asm/boot.h
+@@ -23,7 +23,7 @@
+ #error "Invalid value for CONFIG_PHYSICAL_ALIGN"
+ #endif
+
+-#ifdef CONFIG_KERNEL_BZIP2
++#if defined(CONFIG_KERNEL_BZIP2) || defined(CONFIG_KERNEL_LZMA)
+ #define BOOT_HEAP_SIZE 0x400000
+ #else /* !CONFIG_KERNEL_BZIP2 */
+