aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/x86
diff options
context:
space:
mode:
authorTomasz Maciej Nowak <tomek_n@o2.pl>2020-04-20 19:46:34 +0200
committerDaniel Golle <daniel@makrotopia.org>2020-04-20 18:55:30 +0100
commit9c23ecee577962c3836b6b1b2cdc222c59a257ad (patch)
treec136f3cd3997a385c207f90a839b392f2b3330b9 /target/linux/x86
parenteca6946447aa0be38146314d15f9d86840d8f0ed (diff)
downloadupstream-9c23ecee577962c3836b6b1b2cdc222c59a257ad.tar.gz
upstream-9c23ecee577962c3836b6b1b2cdc222c59a257ad.tar.bz2
upstream-9c23ecee577962c3836b6b1b2cdc222c59a257ad.zip
x86: move packages selection to profiles
This can be rather confusing for contributors, since there are three layers in which they can be added. As for now there are none profiles other than generic (exception: geos) let's move them to these profiles. Being here this commit also removes packages in geode profiles already enabled in kernel config. Signed-off-by: Tomasz Maciej Nowak <tomek_n@o2.pl>
Diffstat (limited to 'target/linux/x86')
-rw-r--r--target/linux/x86/64/target.mk2
-rw-r--r--target/linux/x86/geode/target.mk10
-rw-r--r--target/linux/x86/image/64.mk2
3 files changed, 2 insertions, 12 deletions
diff --git a/target/linux/x86/64/target.mk b/target/linux/x86/64/target.mk
index 02b6c8debf..ece3d1bc9a 100644
--- a/target/linux/x86/64/target.mk
+++ b/target/linux/x86/64/target.mk
@@ -1,7 +1,5 @@
ARCH:=x86_64
BOARDNAME:=x86_64
-DEFAULT_PACKAGES += kmod-e1000e kmod-e1000 kmod-r8169 kmod-igb kmod-bnx2 \
- kmod-forcedeth
define Target/Description
Build images for 64 bit systems including virtualized guests.
diff --git a/target/linux/x86/geode/target.mk b/target/linux/x86/geode/target.mk
index 04ac926cfd..a64d2baaee 100644
--- a/target/linux/x86/geode/target.mk
+++ b/target/linux/x86/geode/target.mk
@@ -1,15 +1,5 @@
BOARDNAME:=AMD Geode based systems
FEATURES += pci usb gpio
-DEFAULT_PACKAGES += \
- kmod-crypto-hw-geode kmod-crypto-cbc \
- kmod-ath5k kmod-ath9k \
- kmod-ledtrig-heartbeat kmod-ledtrig-gpio \
- kmod-ledtrig-netdev hwclock wpad-basic
-# Geos
-DEFAULT_PACKAGES += \
- soloscli linux-atm br2684ctl ppp-mod-pppoa pppdump pppstats \
- hwclock flashrom tc kmod-pppoa kmod-8139cp kmod-mppe \
- kmod-usb-ohci-pci kmod-hwmon-lm90
define Target/Description
Build firmware images for AMD Geode GX/LX based systems (net5501, alix, geos)
diff --git a/target/linux/x86/image/64.mk b/target/linux/x86/image/64.mk
index bde76ceba5..61e6d408d7 100644
--- a/target/linux/x86/image/64.mk
+++ b/target/linux/x86/image/64.mk
@@ -1,5 +1,7 @@
define Device/generic
DEVICE_TITLE := Generic x86/64
+ DEVICE_PACKAGES += kmod-bnx2 kmod-e1000e kmod-e1000 kmod-forcedeth kmod-igb \
+ kmod-r8169
GRUB2_VARIANT := generic
endef
TARGET_DEVICES += generic