aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorLeon M. George <leon@georgemail.eu>2019-07-26 20:34:01 +0200
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-07-26 02:14:45 +0200
commit15f585afc5b66f5addb6667001c303b5fd502ce5 (patch)
tree266ba2744345036537ac88f09667ab06963db46c /target/linux
parentf8ea7c53fd227a9c21f0ca45a2c3345312ea54b5 (diff)
downloadupstream-15f585afc5b66f5addb6667001c303b5fd502ce5.tar.gz
upstream-15f585afc5b66f5addb6667001c303b5fd502ce5.tar.bz2
upstream-15f585afc5b66f5addb6667001c303b5fd502ce5.zip
ath79: add support for Compex WPJ563
Specifications: SoC: QCA9563 DRAM: 128MB DDR2 Flash: 16MB SPI-NOR 2 Gigabit ethernet ports 3×3 2.4GHz on-board radio miniPCIe slot that supports 5GHz radio PoE 24V passive or 36V-56V passive with optional IEEE 802.3af/at USB 3.0 header Installation: To install, either start tftp in bin/targets/ath79/generic/ and use the u-boot prompt over UART: tftpboot 0x80500000 openwrt-ath79-generic-compex_wpj563-squashfs-sysupgrade.bin erase 0x9f680000 +1 erase 0x9f030000 +$filesize cp.b $fileaddr 0x9f030000 $filesize boot The cpximg file can be used with sysupgrade in the stock firmware (add SSH key in luci for root access) or with the built-in cpximg loader. The cpximg loader can be started either by holding the reset button during power up or by entering the u-boot prompt and entering 'cpximg'. Once it's running, a TFTP-server under 192.168.1.1 will accept the image appropriate for the board revision that is etched on the board. For example, if the board is labelled '7A02': tftp -v -m binary 192.168.1.1 -c put openwrt-ath79-generic-compex_wpj563-squashfs-cpximg-7a02.bin MAC addresses: <&uboot 0x2e010> *:71 (label) <&uboot 0x2e018> *:72 <&uboot 0x2e020> *:73 <&uboot 0x2e028> *:74 Only the first two are used (for ethernet), the WiFi modules have separate (valid) addresses. The latter two addresses are not used. Signed-off-by: Leon M. George <leon@georgemail.eu>
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/ath79/dts/qca9563_compex_wpj563.dts145
-rwxr-xr-xtarget/linux/ath79/generic/base-files/etc/board.d/02_network6
-rw-r--r--target/linux/ath79/image/generic.mk12
3 files changed, 161 insertions, 2 deletions
diff --git a/target/linux/ath79/dts/qca9563_compex_wpj563.dts b/target/linux/ath79/dts/qca9563_compex_wpj563.dts
new file mode 100644
index 0000000000..ae9dd5c460
--- /dev/null
+++ b/target/linux/ath79/dts/qca9563_compex_wpj563.dts
@@ -0,0 +1,145 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+#include "qca956x.dtsi"
+
+/ {
+ model = "Compex WPJ563";
+ compatible = "compex,wpj563", "qca,qca9563";
+
+ aliases {
+ label-mac-device = &eth0;
+ led-boot = &led_sig4;
+ led-failsafe = &led_sig4;
+ led-running = &led_sig4;
+ led-upgrade = &led_sig4;
+ };
+
+ beeper {
+ compatible = "gpio-beeper";
+ gpios = <&gpio 19 GPIO_ACTIVE_HIGH>;
+ };
+
+ keys {
+ compatible = "gpio-keys";
+
+ reset {
+ label = "reset";
+ linux,code = <KEY_RESTART>;
+ gpios = <&gpio 2 GPIO_ACTIVE_LOW>;
+ debounce-interval = <60>;
+ };
+ };
+
+ leds {
+ compatible = "gpio-leds";
+
+ sig1 {
+ label = "wpj563:green:sig1";
+ gpios = <&gpio 1 GPIO_ACTIVE_LOW>;
+ };
+
+ sig2 {
+ label = "wpj563:green:sig2";
+ gpios = <&gpio 5 GPIO_ACTIVE_LOW>;
+ };
+
+ sig3 {
+ label = "wpj563:green:sig4";
+ gpios = <&gpio 6 GPIO_ACTIVE_LOW>;
+ };
+
+ led_sig4: sig4 {
+ label = "wpj563:green:sig4";
+ gpios = <&gpio 7 GPIO_ACTIVE_LOW>;
+ };
+ };
+};
+
+&pcie {
+ status = "okay";
+};
+
+&spi {
+ status = "okay";
+
+ num-cs = <1>;
+
+ flash@0 {
+ compatible = "jedec,spi-nor";
+ reg = <0>;
+ spi-max-frequency = <25000000>;
+
+ partitions {
+ compatible = "fixed-partitions";
+ #address-cells = <1>;
+ #size-cells = <1>;
+
+ uboot: partition@0 {
+ label = "u-boot";
+ reg = <0x000000 0x030000>;
+ read-only;
+ };
+
+ partition@30000 {
+ compatible = "denx,uimage";
+ label = "firmware";
+ reg = <0x030000 0xfc0000>;
+ };
+
+ art: partition@ff0000 {
+ label = "art";
+ reg = <0xff0000 0x010000>;
+ read-only;
+ };
+ };
+ };
+};
+
+&mdio0 {
+ status = "okay";
+
+ phy-mask = <0>;
+
+ phy0: ethernet-phy@0 {
+ reg = <0>;
+ phy-mode = "sgmii";
+ qca,mib-poll-interval = <500>;
+
+ qca,ar8327-initvals = <
+ 0x04 0x00080080 /* PORT0 PAD MODE CTRL */
+ 0x7c 0x0000007e /* PORT0_STATUS */
+ >;
+ };
+};
+
+&eth0 {
+ status = "okay";
+
+ pll-data = <0x03000101 0x00000101 0x00001919>;
+
+ mtd-mac-address = <&uboot 0x2e010>;
+ phy-mode = "sgmii";
+ phy-handle = <&phy0>;
+};
+
+&usb_phy0 {
+ status = "okay";
+};
+
+&usb0 {
+ status = "okay";
+};
+
+&uart {
+ status = "okay";
+};
+
+&wmac {
+ status = "okay";
+
+ mtd-cal-data = <&art 0x1000>;
+};
diff --git a/target/linux/ath79/generic/base-files/etc/board.d/02_network b/target/linux/ath79/generic/base-files/etc/board.d/02_network
index e301b6f616..d99e2ed0eb 100755
--- a/target/linux/ath79/generic/base-files/etc/board.d/02_network
+++ b/target/linux/ath79/generic/base-files/etc/board.d/02_network
@@ -135,7 +135,8 @@ ath79_setup_interfaces()
ucidef_add_switch "switch0" \
"0@eth0" "1:lan" "2:lan" "3:lan" "4:lan" "5:wan" "6@eth1"
;;
- compex,wpj344-16m)
+ compex,wpj344-16m|\
+ compex,wpj563)
ucidef_add_switch "switch0" \
"0@eth0" "3:lan" "2:wan"
;;
@@ -383,7 +384,8 @@ ath79_setup_macs()
lan_mac=$(fritz_tffs -n maca -i $(find_mtd_part "tffs (1)"))
wan_mac=$(fritz_tffs -n macb -i $(find_mtd_part "tffs (1)"))
;;
- compex,wpj344-16m)
+ compex,wpj344-16m|\
+ compex,wpj563)
wan_mac=$(mtd_get_mac_binary u-boot 0x2e018)
;;
devolo,magic-2-wifi)
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index 8dc16983e1..adc7772c0e 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -502,6 +502,18 @@ define Device/compex_wpj531-16m
endef
TARGET_DEVICES += compex_wpj531-16m
+define Device/compex_wpj563
+ SOC := qca9563
+ DEVICE_PACKAGES := kmod-usb2 kmod-usb3
+ IMAGE_SIZE := 16128k
+ DEVICE_VENDOR := Compex
+ DEVICE_MODEL := WPJ563
+ SUPPORTED_DEVICES += wpj563
+ IMAGES += cpximg-7a02.bin
+ IMAGE/cpximg-7a02.bin := append-kernel | pad-to $$$$(BLOCKSIZE) | append-rootfs | pad-rootfs | mkmylofw_16m 0x694 2
+endef
+TARGET_DEVICES += compex_wpj563
+
define Device/devolo_dvl1200e
SOC := qca9558
DEVICE_VENDOR := devolo