aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorAlberto Bursi <bobafetthotmail@gmail.com>2020-04-10 22:45:19 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2020-04-13 22:41:37 +0200
commit35f208da3c13cc16227f229f8aea14c4f0a06928 (patch)
treefddebac31b5ee4234e3aa97bd2ead002b6a4a28a /target/linux
parent779a1c84ea16cdb628adba33f40ded88b5f06707 (diff)
downloadupstream-35f208da3c13cc16227f229f8aea14c4f0a06928.tar.gz
upstream-35f208da3c13cc16227f229f8aea14c4f0a06928.tar.bz2
upstream-35f208da3c13cc16227f229f8aea14c4f0a06928.zip
x86: add nforce eth to default packages
forcedeth is necessary to use the integrated ethernet controller of Nvidia nForce chipset. There are PC motherboards with this chipset from 2001 that run 32bit Athlon XP CPUs and more modern ones up to 2009 that can run Intel and AMD 64bit processors, so add this to all non-geode x86 targets. Signed-off-by: Alberto Bursi <bobafetthotmail@gmail.com>
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/x86/64/target.mk3
-rw-r--r--target/linux/x86/image/generic.mk2
-rw-r--r--target/linux/x86/image/legacy.mk2
3 files changed, 4 insertions, 3 deletions
diff --git a/target/linux/x86/64/target.mk b/target/linux/x86/64/target.mk
index 5dd0015a03..6f5f896c8b 100644
--- a/target/linux/x86/64/target.mk
+++ b/target/linux/x86/64/target.mk
@@ -1,6 +1,7 @@
ARCH:=x86_64
BOARDNAME:=x86_64
-DEFAULT_PACKAGES += kmod-button-hotplug kmod-e1000e kmod-e1000 kmod-r8169 kmod-igb kmod-bnx2
+DEFAULT_PACKAGES += kmod-button-hotplug kmod-e1000e kmod-e1000 kmod-r8169 \
+ kmod-igb kmod-bnx2 forcedeth
define Target/Description
Build images for 64 bit systems including virtualized guests.
diff --git a/target/linux/x86/image/generic.mk b/target/linux/x86/image/generic.mk
index 65f7361184..c1a3f8b2e5 100644
--- a/target/linux/x86/image/generic.mk
+++ b/target/linux/x86/image/generic.mk
@@ -2,7 +2,7 @@ define Device/generic
DEVICE_TITLE := Generic x86
DEVICE_PACKAGES += kmod-3c59x kmod-8139too kmod-e100 kmod-e1000 kmod-natsemi \
kmod-ne2k-pci kmod-pcnet32 kmod-r8169 kmod-sis900 kmod-tg3 \
- kmod-via-rhine kmod-via-velocity
+ kmod-via-rhine kmod-via-velocity forcedeth
GRUB2_VARIANT := generic
endef
TARGET_DEVICES += generic
diff --git a/target/linux/x86/image/legacy.mk b/target/linux/x86/image/legacy.mk
index 9909341729..9d6fa5e387 100644
--- a/target/linux/x86/image/legacy.mk
+++ b/target/linux/x86/image/legacy.mk
@@ -2,7 +2,7 @@ define Device/generic
DEVICE_TITLE := Generic x86/legacy
DEVICE_PACKAGES += kmod-3c59x kmod-8139too kmod-e100 kmod-e1000 \
kmod-natsemi kmod-ne2k-pci kmod-pcnet32 kmod-r8169 kmod-sis900 \
- kmod-tg3 kmod-via-rhine kmod-via-velocity
+ kmod-tg3 kmod-via-rhine kmod-via-velocity forcedeth
GRUB2_VARIANT := legacy
endef
TARGET_DEVICES += generic