aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorÁlvaro Fernández Rojas <noltari@gmail.com>2019-09-03 13:01:50 +0200
committerÁlvaro Fernández Rojas <noltari@gmail.com>2019-09-03 19:37:29 +0200
commit5287ac2dfbd0393e23e35e415ddf37f42df9b58e (patch)
tree3fe7a010589ea71ad9bd5217fdf7240bf5bb36ac /target/linux
parentfbbb4eb8b41d59b38f41fe382c6e4108a36aa909 (diff)
downloadupstream-5287ac2dfbd0393e23e35e415ddf37f42df9b58e.tar.gz
upstream-5287ac2dfbd0393e23e35e415ddf37f42df9b58e.tar.bz2
upstream-5287ac2dfbd0393e23e35e415ddf37f42df9b58e.zip
brcm2708: restore UART on RPi 0W, 3B, 3B+ and 4B
Disable Bluetooth and restore UART to GPIOs 14 & 15. Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/brcm2708/image/Makefile1
-rw-r--r--target/linux/brcm2708/image/config-bcm2711-arm64.txt6
-rw-r--r--target/linux/brcm2708/image/config.txt6
-rw-r--r--target/linux/brcm2708/image/distroconfig.txt14
4 files changed, 27 insertions, 0 deletions
diff --git a/target/linux/brcm2708/image/Makefile b/target/linux/brcm2708/image/Makefile
index f1a4bb8dc4..97f127d307 100644
--- a/target/linux/brcm2708/image/Makefile
+++ b/target/linux/brcm2708/image/Makefile
@@ -28,6 +28,7 @@ define Build/boot-common
mcopy -i $@.boot $(KDIR)/LICENCE.broadcom ::
mcopy -i $@.boot cmdline.txt ::
mcopy -i $@.boot $(BOOT_CONFIG) ::config.txt
+ mcopy -i $@.boot distroconfig.txt ::
mcopy -i $@.boot $(IMAGE_KERNEL) ::$(KERNEL_IMG)
$(foreach dts,$(shell echo $(DEVICE_DTS)),mcopy -i $@.boot $(DTS_DIR)/$(dts).dtb ::;)
mmd -i $@.boot ::/overlays
diff --git a/target/linux/brcm2708/image/config-bcm2711-arm64.txt b/target/linux/brcm2708/image/config-bcm2711-arm64.txt
index 1af8ed0dfe..984aab585e 100644
--- a/target/linux/brcm2708/image/config-bcm2711-arm64.txt
+++ b/target/linux/brcm2708/image/config-bcm2711-arm64.txt
@@ -9,3 +9,9 @@
# Force aarch64
arm_64bit=1
+
+# OpenWrt config
+include distroconfig.txt
+
+[all]
+# Place your custom settings here.
diff --git a/target/linux/brcm2708/image/config.txt b/target/linux/brcm2708/image/config.txt
index 0b963a99ae..f8ca1bf2d4 100644
--- a/target/linux/brcm2708/image/config.txt
+++ b/target/linux/brcm2708/image/config.txt
@@ -6,3 +6,9 @@
# For overclocking and various other settings, see:
# https://www.raspberrypi.org/documentation/configuration/config-txt/README.md
################################################################################
+
+# OpenWrt config
+include distroconfig.txt
+
+[all]
+# Place your custom settings here.
diff --git a/target/linux/brcm2708/image/distroconfig.txt b/target/linux/brcm2708/image/distroconfig.txt
new file mode 100644
index 0000000000..54cf44346f
--- /dev/null
+++ b/target/linux/brcm2708/image/distroconfig.txt
@@ -0,0 +1,14 @@
+################################################################################
+# Bootloader configuration - distroconfig.txt
+################################################################################
+
+# Restore PL011 (ttyAMA0) to GPIOs 14 & 15, instead of Mini UART (ttyS0).
+# Mini UART is disabled by default unless "enable_uart=1" is specified,
+# which changes the core frequency to a fixed value and impacts performance.
+# See https://www.raspberrypi.org/documentation/configuration/uart.md
+[pi0w]
+dtoverlay=disable-bt
+[pi3]
+dtoverlay=disable-bt
+[pi4]
+dtoverlay=disable-bt