aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorRene Kjellerup <rk.katana.steel@gmail.com>2017-10-21 17:19:03 -0700
committerHauke Mehrtens <hauke@hauke-m.de>2018-10-07 02:12:06 +0200
commit53be2d2a4eaba78c1f2053589f16cf95ae9c5dd1 (patch)
tree37a8aea1f07f6ec505276b16ac4e8ef6edefe564 /target/linux
parent6e6e7adc8cf70aa8d4f4efb13728960e992d016c (diff)
downloadupstream-53be2d2a4eaba78c1f2053589f16cf95ae9c5dd1.tar.gz
upstream-53be2d2a4eaba78c1f2053589f16cf95ae9c5dd1.tar.bz2
upstream-53be2d2a4eaba78c1f2053589f16cf95ae9c5dd1.zip
bcm53xx: added basic dts for linksys ea6500v2
only thing not working is the b43 5GHz wifi band as upstream kernel doesn't supporthe 0x4360 chip so far Signed-off-by: Rene Kjellerup <rk.katana.steel@gmail.com>
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/bcm53xx/image/Makefile7
-rw-r--r--target/linux/bcm53xx/patches-4.14/315-ARM-dts-BCM5301X-Add-basic-DT-for-Linksys-EA6500-V2.patch64
2 files changed, 70 insertions, 1 deletions
diff --git a/target/linux/bcm53xx/image/Makefile b/target/linux/bcm53xx/image/Makefile
index 596cb5ddb2..e42d612f1f 100644
--- a/target/linux/bcm53xx/image/Makefile
+++ b/target/linux/bcm53xx/image/Makefile
@@ -224,13 +224,18 @@ endef
TARGET_DEVICES += dlink-dir-885l
# Linksys devices are disabled due to problem with 2 TRX partitions
-
define Device/linksys-ea6300-v1
DEVICE_TITLE := Linksys EA6300 V1
DEVICE_PACKAGES := $(B43) $(USB3_PACKAGES)
endef
# TARGET_DEVICES += linksys-ea6300-v1
+define Device/linksys-ea6500-v2
+ DEVICE_TITLE := Linksys EA6500 V2
+ DEVICE_PACKAGES := $(B43) $(USB3_PACKAGES)
+endef
+TARGET_DEVICES += linksys-ea6500-v2
+
define Device/linksys-ea9200
DEVICE_TITLE := Linksys EA9200 V1
DEVICE_PACKAGES := $(BRCMFMAC_43602A1) $(USB3_PACKAGES)
diff --git a/target/linux/bcm53xx/patches-4.14/315-ARM-dts-BCM5301X-Add-basic-DT-for-Linksys-EA6500-V2.patch b/target/linux/bcm53xx/patches-4.14/315-ARM-dts-BCM5301X-Add-basic-DT-for-Linksys-EA6500-V2.patch
new file mode 100644
index 0000000000..3ac8602fa7
--- /dev/null
+++ b/target/linux/bcm53xx/patches-4.14/315-ARM-dts-BCM5301X-Add-basic-DT-for-Linksys-EA6500-V2.patch
@@ -0,0 +1,64 @@
+---
+ arch/arm/boot/dts/Makefile | 1 +
+ arch/arm/boot/dts/bcm4708-linksys-ea6500-v2.dts | 41 +++++++++++++++++++++++++
+ 2 files changed, 42 insertions(+)
+ create mode 100644 arch/arm/boot/dts/bcm4708-linksys-ea6500-v2.dts
+
+--- a/arch/arm/boot/dts/Makefile
++++ b/arch/arm/boot/dts/Makefile
+@@ -82,6 +82,7 @@ dtb-$(CONFIG_ARCH_BCM_5301X) += \
+ bcm4708-asus-rt-ac68u.dtb \
+ bcm4708-buffalo-wzr-1750dhp.dtb \
+ bcm4708-linksys-ea6300-v1.dtb \
++ bcm4708-linksys-ea6500-v2.dtb \
+ bcm4708-luxul-xap-1510.dtb \
+ bcm4708-luxul-xwc-1000.dtb \
+ bcm4708-netgear-r6250.dtb \
+--- /dev/null
++++ b/arch/arm/boot/dts/bcm4708-linksys-ea6500-v2.dts
+@@ -0,0 +1,45 @@
++// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
++/*
++ * Copyright (C) 2017 Rafał Miłecki <rafal@milecki.pl>
++ * Copyright (C) 2018 Rene Kjellerup <rk.katana.steel@gmail.com>
++ *
++ */
++
++/dts-v1/;
++
++#include "bcm4708.dtsi"
++#include "bcm5301x-nand-cs0-bch8.dtsi"
++
++/ {
++ compatible = "linksys,ea6500-v2", "brcm,bcm4708";
++ model = "Linksys EA6500 V2";
++
++ chosen {
++ bootargs = "console=ttyS0,115200";
++ };
++
++ memory {
++ reg = <0x00000000 0x08000000>;
++ };
++
++ gpio-keys {
++ compatible = "gpio-keys";
++ #address-cells = <1>;
++ #size-cells = <0>;
++
++ wps {
++ label = "WPS";
++ linux,code = <KEY_WPS_BUTTON>;
++ gpios = <&chipcommon 7 GPIO_ACTIVE_LOW>;
++ };
++
++ restart {
++ label = "Reset";
++ linux,code = <KEY_RESTART>;
++ gpios = <&chipcommon 11 GPIO_ACTIVE_LOW>;
++ };
++ };
++};
++&usb3_phy {
++ status = "okay";
++};