aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorDavid Bauer <mail@david-bauer.net>2019-08-27 23:55:12 +0200
committerDavid Bauer <mail@david-bauer.net>2019-08-31 10:31:00 +0200
commit607dfdf211bebb5043cbc0267c1e2c3e3c2514b4 (patch)
tree42b687f35a9bb1796d574295a43a5804d1c46e96 /target/linux
parent527832e54bf3bc4d699a145ae66f34230246f0a9 (diff)
downloadupstream-607dfdf211bebb5043cbc0267c1e2c3e3c2514b4.tar.gz
upstream-607dfdf211bebb5043cbc0267c1e2c3e3c2514b4.tar.bz2
upstream-607dfdf211bebb5043cbc0267c1e2c3e3c2514b4.zip
ramips: add factory image for NETGEAR R6220
This adds an easy-installation factory image for the NETGEAR R6220 router. The factory image can either be flashed via the vendor Web-UI or the bootloader using nmrpflash. Tested with NETGEAR V1.1.0.86 firmware. Signed-off-by: David Bauer <mail@david-bauer.net>
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/ramips/image/mt7621.mk7
1 files changed, 6 insertions, 1 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 5dc8efe7c5..a00e6280c7 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -397,7 +397,12 @@ define Device/netgear_r6220
KERNEL_SIZE := 4096k
IMAGE_SIZE := 28672k
UBINIZE_OPTS := -E 5
- IMAGES += kernel.bin rootfs.bin
+ SERCOMM_HWID := AYA
+ SERCOMM_HWVER := A001
+ SERCOMM_SWVER := 0x0086
+ IMAGES += factory.img kernel.bin rootfs.bin
+ IMAGE/factory.img := pad-extra 2048k | append-kernel | pad-to 6144k | append-ubi | \
+ pad-to $$$$(BLOCKSIZE) | sercom-footer | pad-to 128 | zip R6220.bin | sercom-seal
IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
IMAGE/kernel.bin := append-kernel
IMAGE/rootfs.bin := append-ubi | check-size $$$$(IMAGE_SIZE)