aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-07-21 17:28:54 +0200
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-07-25 23:19:19 +0200
commit739d282c2fc83906c1cd75d01e86fc2ab8dd625c (patch)
tree0178c3f475a7b2a001efda5f0810b626a0335981 /target/linux
parenta956c14d6aa49973b713120cede96bee41f2cd25 (diff)
downloadupstream-739d282c2fc83906c1cd75d01e86fc2ab8dd625c.tar.gz
upstream-739d282c2fc83906c1cd75d01e86fc2ab8dd625c.tar.bz2
upstream-739d282c2fc83906c1cd75d01e86fc2ab8dd625c.zip
mediatek: remove condition in Device/Default
The current condition with part of the variables set dependent on the subtarget in Device/Default isn't really nice to read and also defeats the purpose of having a default node. This removes the special settings for mt7623 and moves them to the individual devices, which is not much of a problem as there are actually just two of them and they partly use different settings anyway. While at it, slightly adjust the order of variables and wrap some long lines. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/mediatek/image/Makefile18
-rw-r--r--target/linux/mediatek/image/mt7623.mk14
2 files changed, 16 insertions, 16 deletions
diff --git a/target/linux/mediatek/image/Makefile b/target/linux/mediatek/image/Makefile
index db702509ed..724bf430ef 100644
--- a/target/linux/mediatek/image/Makefile
+++ b/target/linux/mediatek/image/Makefile
@@ -21,21 +21,17 @@ endef
# default all platform image(fit) build
define Device/Default
PROFILES = Default $$(DEVICE_NAME)
- KERNEL_NAME := zImage
+ KERNEL_NAME := Image
+ KERNEL = kernel-bin | lzma | \
+ fit lzma $$(KDIR)/image-$$(firstword $$(DEVICE_DTS)).dtb
+ KERNEL_INITRAMFS = kernel-bin | lzma | \
+ fit lzma $$(KDIR)/image-$$(firstword $$(DEVICE_DTS)).dtb
FILESYSTEMS := squashfs
DEVICE_DTS_DIR := $(DTS_DIR)
IMAGES := sysupgrade.bin
- IMAGE/sysupgrade.bin := append-kernel | pad-to 128k | append-rootfs | pad-rootfs | append-metadata
+ IMAGE/sysupgrade.bin := append-kernel | pad-to 128k | append-rootfs | \
+ pad-rootfs | append-metadata
SUPPORTED_DEVICES := $(subst _,$(comma),$(1))
-ifeq ($(SUBTARGET),mt7623)
- KERNEL_NAME := zImage
- KERNEL := kernel-bin | append-dtb | uImage none
- KERNEL_INITRAMFS := kernel-bin | append-dtb | uImage none
-else
- KERNEL_NAME := Image
- KERNEL = kernel-bin | lzma | fit lzma $$(KDIR)/image-$$(firstword $$(DEVICE_DTS)).dtb
- KERNEL_INITRAMFS = kernel-bin | lzma | fit lzma $$(KDIR)/image-$$(firstword $$(DEVICE_DTS)).dtb
-endif
endef
include $(SUBTARGET).mk
diff --git a/target/linux/mediatek/image/mt7623.mk b/target/linux/mediatek/image/mt7623.mk
index 1c2dcf7624..bdd3820ed3 100644
--- a/target/linux/mediatek/image/mt7623.mk
+++ b/target/linux/mediatek/image/mt7623.mk
@@ -29,14 +29,15 @@ define Device/bpi_bananapi-r2
DEVICE_VENDOR := Bpi
DEVICE_MODEL := Banana Pi R2
DEVICE_DTS := mt7623n-bananapi-bpi-r2
- SUPPORTED_DEVICES := bananapi,bpi-r2
+ KERNEL_NAME := zImage
+ KERNEL := kernel-bin | fit none $$(DTS_DIR)/$$(DEVICE_DTS).dtb
+ KERNEL_INITRAMFS :=
DEVICE_PACKAGES := kmod-fs-vfat kmod-nls-cp437 kmod-nls-iso8859-1 kmod-mmc \
mkf2fs e2fsprogs kmod-usb-ohci kmod-usb2 kmod-usb3 kmod-ata-ahci-mtk
UBOOT_TARGET := mt7623n_bpir2
IMAGES := img.gz
IMAGE/img.gz := banana-pi-sdcard | gzip | append-metadata
- KERNEL := kernel-bin | fit none $$(DTS_DIR)/$$(DEVICE_DTS).dtb
- KERNEL_INITRAMFS :=
+ SUPPORTED_DEVICES := bananapi,bpi-r2
endef
TARGET_DEVICES += bpi_bananapi-r2
@@ -45,9 +46,12 @@ define Device/unielec_u7623-02-emmc-512m
DEVICE_MODEL := U7623-02
DEVICE_VARIANT := eMMC/512MB RAM
DEVICE_DTS := mt7623a-unielec-u7623-02-emmc-512m
- IMAGES := sysupgrade-emmc.bin.gz
- IMAGE/sysupgrade-emmc.bin.gz := sysupgrade-emmc | gzip | append-metadata
+ KERNEL_NAME := zImage
+ KERNEL := kernel-bin | append-dtb | uImage none
+ KERNEL_INITRAMFS := kernel-bin | append-dtb | uImage none
DEVICE_PACKAGES := kmod-fs-vfat kmod-nls-cp437 kmod-nls-iso8859-1 kmod-mmc \
mkf2fs e2fsprogs kmod-usb-ohci kmod-usb2 kmod-usb3 kmod-ata-ahci-mtk
+ IMAGES := sysupgrade-emmc.bin.gz
+ IMAGE/sysupgrade-emmc.bin.gz := sysupgrade-emmc | gzip | append-metadata
endef
TARGET_DEVICES += unielec_u7623-02-emmc-512m