aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2009-05-22 09:46:02 +0000
committerGabor Juhos <juhosg@openwrt.org>2009-05-22 09:46:02 +0000
commita51ef0ecf89d7746a4ecd901e7c40fa637c08e84 (patch)
tree6dbd5d6602873b2efa8ef84391caec7ba4cc0d22 /target/linux
parent118c184e5049f06dcedf9edbfe9e1f2ca9f25c76 (diff)
downloadupstream-a51ef0ecf89d7746a4ecd901e7c40fa637c08e84.tar.gz
upstream-a51ef0ecf89d7746a4ecd901e7c40fa637c08e84.tar.bz2
upstream-a51ef0ecf89d7746a4ecd901e7c40fa637c08e84.zip
generic-2.6/2.6.30: refresh patches
SVN-Revision: 15981
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/generic-2.6/patches-2.6.30/051-squashfs_pcomp.patch4
-rw-r--r--target/linux/generic-2.6/patches-2.6.30/052-pcomp_lzma_support.patch4
-rw-r--r--target/linux/generic-2.6/patches-2.6.30/053-squashfs_lzma.patch2
-rw-r--r--target/linux/generic-2.6/patches-2.6.30/970-ocf_kbuild_integration.patch4
4 files changed, 7 insertions, 7 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.30/051-squashfs_pcomp.patch b/target/linux/generic-2.6/patches-2.6.30/051-squashfs_pcomp.patch
index 271c4e5c8b..fc2a731dde 100644
--- a/target/linux/generic-2.6/patches-2.6.30/051-squashfs_pcomp.patch
+++ b/target/linux/generic-2.6/patches-2.6.30/051-squashfs_pcomp.patch
@@ -201,7 +201,7 @@
goto failure;
}
-@@ -284,17 +311,18 @@ failed_mount:
+@@ -294,17 +321,18 @@ failed_mount:
kfree(msblk->inode_lookup_table);
kfree(msblk->fragment_index);
kfree(msblk->id_table);
@@ -223,7 +223,7 @@
}
-@@ -333,7 +361,7 @@ static void squashfs_put_super(struct su
+@@ -346,7 +374,7 @@ static void squashfs_put_super(struct su
kfree(sbi->id_table);
kfree(sbi->fragment_index);
kfree(sbi->meta_index);
diff --git a/target/linux/generic-2.6/patches-2.6.30/052-pcomp_lzma_support.patch b/target/linux/generic-2.6/patches-2.6.30/052-pcomp_lzma_support.patch
index c5265e9b29..3259db40a8 100644
--- a/target/linux/generic-2.6/patches-2.6.30/052-pcomp_lzma_support.patch
+++ b/target/linux/generic-2.6/patches-2.6.30/052-pcomp_lzma_support.patch
@@ -713,7 +713,7 @@
+MODULE_AUTHOR("Felix Fietkau <nbd@openwrt.org>");
--- a/crypto/Kconfig
+++ b/crypto/Kconfig
-@@ -728,6 +728,12 @@ config CRYPTO_ZLIB
+@@ -758,6 +758,12 @@ config CRYPTO_ZLIB
help
This is the zlib algorithm.
@@ -728,7 +728,7 @@
select CRYPTO_ALGAPI
--- a/crypto/Makefile
+++ b/crypto/Makefile
-@@ -73,6 +73,7 @@ obj-$(CONFIG_CRYPTO_SEED) += seed.o
+@@ -75,6 +75,7 @@ obj-$(CONFIG_CRYPTO_SEED) += seed.o
obj-$(CONFIG_CRYPTO_SALSA20) += salsa20_generic.o
obj-$(CONFIG_CRYPTO_DEFLATE) += deflate.o
obj-$(CONFIG_CRYPTO_ZLIB) += zlib.o
diff --git a/target/linux/generic-2.6/patches-2.6.30/053-squashfs_lzma.patch b/target/linux/generic-2.6/patches-2.6.30/053-squashfs_lzma.patch
index b632e05926..aea4aced70 100644
--- a/target/linux/generic-2.6/patches-2.6.30/053-squashfs_lzma.patch
+++ b/target/linux/generic-2.6/patches-2.6.30/053-squashfs_lzma.patch
@@ -188,7 +188,7 @@
if (err < 0)
goto failed_mount;
-@@ -305,21 +342,16 @@ allocate_root:
+@@ -315,21 +352,16 @@ allocate_root:
return 0;
failed_mount:
diff --git a/target/linux/generic-2.6/patches-2.6.30/970-ocf_kbuild_integration.patch b/target/linux/generic-2.6/patches-2.6.30/970-ocf_kbuild_integration.patch
index b24d59cfff..bf229eab82 100644
--- a/target/linux/generic-2.6/patches-2.6.30/970-ocf_kbuild_integration.patch
+++ b/target/linux/generic-2.6/patches-2.6.30/970-ocf_kbuild_integration.patch
@@ -1,6 +1,6 @@
--- a/crypto/Kconfig
+++ b/crypto/Kconfig
-@@ -778,6 +778,8 @@ config CRYPTO_ANSI_CPRNG
+@@ -784,6 +784,8 @@ config CRYPTO_ANSI_CPRNG
for cryptographic modules. Uses the Algorithm specified in
ANSI X9.31 A.2.4
@@ -11,7 +11,7 @@
endif # if CRYPTO
--- a/crypto/Makefile
+++ b/crypto/Makefile
-@@ -85,6 +85,11 @@ obj-$(CONFIG_CRYPTO_ANSI_CPRNG) += ansi_
+@@ -86,6 +86,11 @@ obj-$(CONFIG_CRYPTO_ANSI_CPRNG) += ansi_
obj-$(CONFIG_CRYPTO_TEST) += tcrypt.o
#