aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2020-04-20 19:21:50 +0100
committerDaniel Golle <daniel@makrotopia.org>2020-04-20 19:24:18 +0100
commitbe6543c53994b873a61689261f54ef2353165453 (patch)
tree93152f3cb76c50f1d75c7d32bf850c4526d28391 /target/linux
parent9c23ecee577962c3836b6b1b2cdc222c59a257ad (diff)
downloadupstream-be6543c53994b873a61689261f54ef2353165453.tar.gz
upstream-be6543c53994b873a61689261f54ef2353165453.tar.bz2
upstream-be6543c53994b873a61689261f54ef2353165453.zip
x86: really remove packages already enabled in kconfig
This commit really removes packages in geode profiles already enabled in kernel config. Fixes: 9c23ecee57 ("x86: move packages selection to profiles") Reported-by: Tomasz Maciej Nowak <tomek_n@o2.pl> Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/x86/image/geode.mk7
1 files changed, 3 insertions, 4 deletions
diff --git a/target/linux/x86/image/geode.mk b/target/linux/x86/image/geode.mk
index 0b463e36ed..4ebb14888a 100644
--- a/target/linux/x86/image/geode.mk
+++ b/target/linux/x86/image/geode.mk
@@ -1,7 +1,7 @@
define Device/generic
DEVICE_TITLE := Generic x86/Geode
DEVICE_PACKAGES += kmod-crypto-cbc kmod-crypto-hw-geode kmod-ledtrig-gpio \
- kmod-ledtrig-heartbeat kmod-ledtrig-netdev kmod-via-rhine
+ kmod-ledtrig-heartbeat kmod-ledtrig-netdev
GRUB2_VARIANT := legacy
endef
TARGET_DEVICES += generic
@@ -9,8 +9,7 @@ TARGET_DEVICES += generic
define Device/geos
$(call Device/generic)
DEVICE_TITLE := Traverse Technologies Geos
- DEVICE_PACKAGES += br2684ctl flashrom kmod-8139cp kmod-hwmon-lm90 kmod-mppe \
- kmod-pppoa kmod-usb-ohci-pci linux-atm ppp-mod-pppoa pppdump pppstats \
- soloscli tc
+ DEVICE_PACKAGES += br2684ctl flashrom kmod-hwmon-lm90 kmod-mppe kmod-pppoa \
+ kmod-usb-ohci-pci linux-atm ppp-mod-pppoa pppdump pppstats soloscli tc
endef
TARGET_DEVICES += geos