aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-01-10 15:26:38 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-01-10 15:26:38 +0000
commite66f1292aa88ba6db04fab07836cf70db28b9b93 (patch)
tree51ff7b5ec01ec4a91381b18d6daac0f01442a021 /target/linux
parent54602a82a4a632d5546f948d8b7372953dde7477 (diff)
downloadupstream-e66f1292aa88ba6db04fab07836cf70db28b9b93.tar.gz
upstream-e66f1292aa88ba6db04fab07836cf70db28b9b93.tar.bz2
upstream-e66f1292aa88ba6db04fab07836cf70db28b9b93.zip
ramips: simplify mkimage kernel loadaddr/entry handling
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 43906
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/ramips/image/Makefile20
1 files changed, 4 insertions, 16 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index e4effa6f5c..18c1330bf6 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -22,21 +22,9 @@ define Image/Build/Initramfs
$(call Image/Build/Profile/$(PROFILE),initramfs)
endef
-ifeq ($(CONFIG_SOC_RT288X),y)
-define kernel_entry
--a 0x88000000 -e 0x88000000
-endef
-else
-ifeq ($(CONFIG_SOC_MT7621),y)
-define kernel_entry
--a 0x80001000 -e 0x80001000
-endef
-else
-define kernel_entry
--a 0x80000000 -e 0x80000000
-endef
-endif
-endif
+loadaddr-y := 0x80000000
+loadaddr-$(CONFIG_TARGET_ramips_rt288x) := 0x88000000
+loadaddr-$(CONFIG_TARGET_ramips_mt7621) := 0x80001000
define MkCombineduImage
$(call PatchKernelLzma,$(2),$(3))
@@ -59,7 +47,7 @@ endef
# $(3), output filename
define MkImage
$(eval imagename=$(if $(4),$(4),MIPS OpenWrt Linux-$(LINUX_VERSION)))
- -mkimage -A mips -O linux -T kernel -C $(1) $(call kernel_entry)\
+ -mkimage -A mips -O linux -T kernel -C $(1) -a $(loadaddr-y) -e $(loadaddr-y) \
-n "$(imagename)" \
-d $(2) $(3)
endef