aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-04-07 10:34:33 +0200
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-04-08 13:46:30 +0200
commitf761f4052c411bababed2d2e9d8dc3f43380e4ee (patch)
tree8436978a65ddb3d5dad2a504f77552a5eb79163f /target/linux
parent48b4aab80cd34682616bf7f12c41e35e27a49504 (diff)
downloadupstream-f761f4052c411bababed2d2e9d8dc3f43380e4ee.tar.gz
upstream-f761f4052c411bababed2d2e9d8dc3f43380e4ee.tar.bz2
upstream-f761f4052c411bababed2d2e9d8dc3f43380e4ee.zip
ramips: mt7621: harmonize naming scheme for Mikrotik
So far, image/device/board names for Mikrotik devices in mt7621 have been used quite inconsistently. This patch harmonizes the naming scheme by applying the same style as used lately in ath79, i.e. using "RouterBOARD" as separate word in the model name (instead of RB prefix for the number) and deriving the board/device name from that (= make lower case and replace spaces by hyphens). This style has already been used for most the model/DEVICE_MODEL variables in mt7621, so this is essentially just adjusting the remaining variables to that. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/ramips/dts/mt7621_mikrotik_routerboard-750gr3.dts (renamed from target/linux/ramips/dts/mt7621_mikrotik_rb750gr3.dts)6
-rw-r--r--target/linux/ramips/dts/mt7621_mikrotik_routerboard-m11g.dts (renamed from target/linux/ramips/dts/mt7621_mikrotik_rbm11g.dts)14
-rw-r--r--target/linux/ramips/dts/mt7621_mikrotik_routerboard-m33g.dts (renamed from target/linux/ramips/dts/mt7621_mikrotik_rbm33g.dts)4
-rw-r--r--target/linux/ramips/image/mt7621.mk18
-rwxr-xr-xtarget/linux/ramips/mt7621/base-files/etc/board.d/01_leds2
-rwxr-xr-xtarget/linux/ramips/mt7621/base-files/etc/board.d/02_network12
-rwxr-xr-xtarget/linux/ramips/mt7621/base-files/etc/board.d/03_gpio_switches2
-rw-r--r--target/linux/ramips/mt7621/base-files/etc/uci-defaults/04_led_migration10
-rwxr-xr-xtarget/linux/ramips/mt7621/base-files/lib/upgrade/platform.sh6
9 files changed, 42 insertions, 32 deletions
diff --git a/target/linux/ramips/dts/mt7621_mikrotik_rb750gr3.dts b/target/linux/ramips/dts/mt7621_mikrotik_routerboard-750gr3.dts
index e268b233d4..3f37155f24 100644
--- a/target/linux/ramips/dts/mt7621_mikrotik_rb750gr3.dts
+++ b/target/linux/ramips/dts/mt7621_mikrotik_routerboard-750gr3.dts
@@ -7,7 +7,7 @@
#include <dt-bindings/gpio/gpio.h>
/ {
- compatible = "mikrotik,rb750gr3", "mediatek,mt7621-soc";
+ compatible = "mikrotik,routerboard-750gr3", "mediatek,mt7621-soc";
model = "MikroTik RouterBOARD 750Gr3";
aliases {
@@ -25,13 +25,13 @@
compatible = "gpio-leds";
pwr {
- label = "rb750gr3:blue:pwr";
+ label = "routerboard-750gr3:blue:pwr";
gpios = <&gpio 16 GPIO_ACTIVE_HIGH>;
default-state = "on";
};
led_usr: usr {
- label = "rb750gr3:green:usr";
+ label = "routerboard-750gr3:green:usr";
gpios = <&gpio 0 GPIO_ACTIVE_HIGH>;
};
};
diff --git a/target/linux/ramips/dts/mt7621_mikrotik_rbm11g.dts b/target/linux/ramips/dts/mt7621_mikrotik_routerboard-m11g.dts
index aae899c9a6..bd58aea951 100644
--- a/target/linux/ramips/dts/mt7621_mikrotik_rbm11g.dts
+++ b/target/linux/ramips/dts/mt7621_mikrotik_routerboard-m11g.dts
@@ -6,7 +6,7 @@
#include <dt-bindings/gpio/gpio.h>
/ {
- compatible = "mikrotik,rbm11g", "mediatek,mt7621-soc";
+ compatible = "mikrotik,routerboard-m11g", "mediatek,mt7621-soc";
model = "MikroTik RouterBOARD M11G";
aliases {
@@ -24,32 +24,32 @@
compatible = "gpio-leds";
led_usr: usr {
- label = "rbm11g:green:usr";
+ label = "routerboard-m11g:green:usr";
gpios = <&gpio 0 GPIO_ACTIVE_HIGH>;
};
rssi0 {
- label = "rbm11g:green:rssi0";
+ label = "routerboard-m11g:green:rssi0";
gpios = <&gpio 22 GPIO_ACTIVE_LOW>;
};
rssi1 {
- label = "rbm11g:green:rssi1";
+ label = "routerboard-m11g:green:rssi1";
gpios = <&gpio 23 GPIO_ACTIVE_LOW>;
};
rssi2 {
- label = "rbm11g:green:rssi2";
+ label = "routerboard-m11g:green:rssi2";
gpios = <&gpio 24 GPIO_ACTIVE_LOW>;
};
rssi3 {
- label = "rbm11g:green:rssi3";
+ label = "routerboard-m11g:green:rssi3";
gpios = <&gpio 25 GPIO_ACTIVE_LOW>;
};
rssi4 {
- label = "rbm11g:green:rssi4";
+ label = "routerboard-m11g:green:rssi4";
gpios = <&gpio 26 GPIO_ACTIVE_LOW>;
};
};
diff --git a/target/linux/ramips/dts/mt7621_mikrotik_rbm33g.dts b/target/linux/ramips/dts/mt7621_mikrotik_routerboard-m33g.dts
index f7889bd68a..19e1a71e99 100644
--- a/target/linux/ramips/dts/mt7621_mikrotik_rbm33g.dts
+++ b/target/linux/ramips/dts/mt7621_mikrotik_routerboard-m33g.dts
@@ -6,7 +6,7 @@
#include <dt-bindings/gpio/gpio.h>
/ {
- compatible = "mikrotik,rbm33g", "mediatek,mt7621-soc";
+ compatible = "mikrotik,routerboard-m33g", "mediatek,mt7621-soc";
model = "MikroTik RouterBOARD M33G";
aliases {
@@ -24,7 +24,7 @@
compatible = "gpio-leds";
led_usr: usr {
- label = "rbm33g:green:usr";
+ label = "routerboard-m33g:green:usr";
gpios = <&gpio 0 GPIO_ACTIVE_HIGH>;
};
};
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 0ecd70685b..ec9d8aacae 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -495,25 +495,27 @@ define Device/MikroTik
check-size
endef
-define Device/mikrotik_rb750gr3
+define Device/mikrotik_routerboard-750gr3
$(Device/MikroTik)
- DEVICE_MODEL := RouterBOARD RB750G
- DEVICE_VARIANT := r3
+ DEVICE_MODEL := RouterBOARD 750Gr3
DEVICE_PACKAGES += kmod-gpio-beeper
+ SUPPORTED_DEVICES += mikrotik,rb750gr3
endef
-TARGET_DEVICES += mikrotik_rb750gr3
+TARGET_DEVICES += mikrotik_routerboard-750gr3
-define Device/mikrotik_rbm11g
+define Device/mikrotik_routerboard-m11g
$(Device/MikroTik)
DEVICE_MODEL := RouterBOARD M11G
+ SUPPORTED_DEVICES += mikrotik,rbm11g
endef
-TARGET_DEVICES += mikrotik_rbm11g
+TARGET_DEVICES += mikrotik_routerboard-m11g
-define Device/mikrotik_rbm33g
+define Device/mikrotik_routerboard-m33g
$(Device/MikroTik)
DEVICE_MODEL := RouterBOARD M33G
+ SUPPORTED_DEVICES += mikrotik,rbm33g
endef
-TARGET_DEVICES += mikrotik_rbm33g
+TARGET_DEVICES += mikrotik_routerboard-m33g
define Device/mqmaker_witi
IMAGE_SIZE := 16064k
diff --git a/target/linux/ramips/mt7621/base-files/etc/board.d/01_leds b/target/linux/ramips/mt7621/base-files/etc/board.d/01_leds
index 66739a7536..cc114da4ee 100755
--- a/target/linux/ramips/mt7621/base-files/etc/board.d/01_leds
+++ b/target/linux/ramips/mt7621/base-files/etc/board.d/01_leds
@@ -34,7 +34,7 @@ gnubee,gb-pc2)
ucidef_set_led_netdev "lan1" "lan1" "$boardname:green:lan1" "lan1"
ucidef_set_led_netdev "lan2" "lan2" "$boardname:green:lan2" "lan2"
;;
-mikrotik,rbm11g)
+mikrotik,routerboard-m11g)
ucidef_set_rssimon "wlan0" "200000" "1"
ucidef_set_led_rssi "rssilow" "RSSILOW" "$boardname:green:rssi0" "wlan0" "1" "100"
ucidef_set_led_rssi "rssimediumlow" "RSSIMEDIUMLOW" "$boardname:green:rssi1" "wlan0" "20" "100"
diff --git a/target/linux/ramips/mt7621/base-files/etc/board.d/02_network b/target/linux/ramips/mt7621/base-files/etc/board.d/02_network
index f654574e14..f573a049ce 100755
--- a/target/linux/ramips/mt7621/base-files/etc/board.d/02_network
+++ b/target/linux/ramips/mt7621/base-files/etc/board.d/02_network
@@ -14,7 +14,7 @@ ramips_setup_interfaces()
;;
asiarf,ap7621-nv1|\
lenovo,newifi-d1|\
- mikrotik,rbm33g|\
+ mikrotik,routerboard-m33g|\
xiaomi,mir3g|\
xiaomi,mir3g-v2)
ucidef_set_interfaces_lan_wan "lan1 lan2" "wan"
@@ -31,7 +31,7 @@ ramips_setup_interfaces()
linksys,re6500)
ucidef_set_interface_lan "lan1 lan2 lan3 lan4"
;;
- mikrotik,rbm11g|\
+ mikrotik,routerboard-m11g|\
netgear,ex6150|\
thunder,timecloud|\
tplink,re350-v1|\
@@ -39,7 +39,7 @@ ramips_setup_interfaces()
ubnt,unifi-nanohd)
ucidef_set_interface_lan "lan"
;;
- mikrotik,rb750gr3)
+ mikrotik,routerboard-750gr3)
ucidef_set_interfaces_lan_wan "lan2 lan3 lan4 lan5" "wan"
;;
ubiquiti,edgerouterx|\
@@ -89,9 +89,9 @@ ramips_setup_macs()
wan_mac=$(mtd_get_mac_ascii u-boot-env wanaddr)
label_mac=$wan_mac
;;
- mikrotik,rb750gr3|\
- mikrotik,rbm11g|\
- mikrotik,rbm33g)
+ mikrotik,routerboard-750gr3|\
+ mikrotik,routerboard-m11g|\
+ mikrotik,routerboard-m33g)
label_mac=$(mtd_get_mac_binary hard_config 0x10)
;;
zbtlink,zbt-we1326|\
diff --git a/target/linux/ramips/mt7621/base-files/etc/board.d/03_gpio_switches b/target/linux/ramips/mt7621/base-files/etc/board.d/03_gpio_switches
index d3bc85f827..511d9deed8 100755
--- a/target/linux/ramips/mt7621/base-files/etc/board.d/03_gpio_switches
+++ b/target/linux/ramips/mt7621/base-files/etc/board.d/03_gpio_switches
@@ -7,7 +7,7 @@ board_config_update
board=$(board_name)
case "$board" in
-mikrotik,rb750gr3)
+mikrotik,routerboard-750gr3)
ucidef_add_gpio_switch "poe_passthrough" "PoE Passthrough" "17"
;;
telco-electronics,x1)
diff --git a/target/linux/ramips/mt7621/base-files/etc/uci-defaults/04_led_migration b/target/linux/ramips/mt7621/base-files/etc/uci-defaults/04_led_migration
index e745c2c5d4..73140fd7d5 100644
--- a/target/linux/ramips/mt7621/base-files/etc/uci-defaults/04_led_migration
+++ b/target/linux/ramips/mt7621/base-files/etc/uci-defaults/04_led_migration
@@ -4,11 +4,19 @@
. /lib/functions/migrations.sh
board=$(board_name)
+boardonly="${board##*,}"
case "$board" in
+mikrotik,routerboard-750gr3)
+ migrate_leds "^rb750gr3:=$boardonly:"
+mikrotik,routerboard-m11g)
+ migrate_leds "^rbm11g:=$boardonly:"
+mikrotik,routerboard-m33g)
+ migrate_leds "^rbm33g:=$boardonly:"
netgear,wndr3700-v5)
- migrate_leds "^wndr3700v5:=wndr3700-v5:"
+ migrate_leds "^wndr3700v5:=$boardonly:"
;;
+
esac
migrations_apply system
diff --git a/target/linux/ramips/mt7621/base-files/lib/upgrade/platform.sh b/target/linux/ramips/mt7621/base-files/lib/upgrade/platform.sh
index ad10dcbdaa..afb3a52a82 100755
--- a/target/linux/ramips/mt7621/base-files/lib/upgrade/platform.sh
+++ b/target/linux/ramips/mt7621/base-files/lib/upgrade/platform.sh
@@ -27,9 +27,9 @@ platform_do_upgrade() {
fi
}
;;
- mikrotik,rb750gr3|\
- mikrotik,rbm11g|\
- mikrotik,rbm33g)
+ mikrotik,routerboard-750gr3|\
+ mikrotik,routerboard-m11g|\
+ mikrotik,routerboard-m33g)
[ -z "$(rootfs_type)" ] && mtd erase firmware
;;
asus,rt-ac65p|\