aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorPaul Spooren <mail@aparcar.org>2020-04-09 23:54:52 -1000
committerDaniel Golle <daniel@makrotopia.org>2020-04-14 23:38:08 +0100
commitf814121600e5cf43fd75fe93e5b1b54f65b71bcd (patch)
treefc8ec38bf7ed2a0f80b6d57564684f9c4cfb85b5 /target/linux
parentc737a9ee6a9c47b6e553ac81bf293b1161e59799 (diff)
downloadupstream-f814121600e5cf43fd75fe93e5b1b54f65b71bcd.tar.gz
upstream-f814121600e5cf43fd75fe93e5b1b54f65b71bcd.tar.bz2
upstream-f814121600e5cf43fd75fe93e5b1b54f65b71bcd.zip
x86: append metadata to combined images
Now that the x86 target uses the new image generation code we can also attach metadata to the created images. As currently the `SUPPORTED_DEVICES` list is empty, no JSON metadata is attached, however the signing happens in the same step. This results in signature verification for x86 images. Signed-off-by: Paul Spooren <mail@aparcar.org>
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/x86/image/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/target/linux/x86/image/Makefile b/target/linux/x86/image/Makefile
index 7a474e7a6e..77516a4a9d 100644
--- a/target/linux/x86/image/Makefile
+++ b/target/linux/x86/image/Makefile
@@ -113,15 +113,15 @@ endef
DEVICE_VARS += GRUB2_VARIANT
define Device/Default
ARTIFACT/image.iso := grub-config iso | iso
- IMAGE/combined.img := grub-config pc | combined | grub-install
- IMAGE/combined.img.gz := grub-config pc | combined | grub-install | gzip
+ IMAGE/combined.img := grub-config pc | combined | grub-install | append-metadata
+ IMAGE/combined.img.gz := grub-config pc | combined | grub-install | gzip | append-metadata
IMAGE/combined.vdi := grub-config pc | combined | grub-install | qemu-image vdi
IMAGE/combined.vmdk := grub-config pc | combined | grub-install | qemu-image vmdk
IMAGE/rootfs.img := append-rootfs
IMAGE/rootfs.img.gz := append-rootfs | gzip
ARTIFACT/image-efi.iso := grub-config iso | iso efi
- IMAGE/combined-efi.img := grub-config efi | combined efi | grub-install efi
- IMAGE/combined-efi.img.gz := grub-config efi | combined efi | grub-install efi | gzip
+ IMAGE/combined-efi.img := grub-config efi | combined efi | grub-install efi | append-metadata
+ IMAGE/combined-efi.img.gz := grub-config efi | combined efi | grub-install efi | gzip | append-metadata
IMAGE/combined-efi.vdi := grub-config efi | combined efi | grub-install efi | qemu-image vdi
IMAGE/combined-efi.vmdk := grub-config efi | combined efi | grub-install efi | qemu-image vmdk
ifeq ($(CONFIG_TARGET_IMAGES_GZIP),y)