aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2013-01-09 09:04:09 +0000
committerJohn Crispin <john@openwrt.org>2013-01-09 09:04:09 +0000
commit4834d09a3f91622bb78e2163181a976933a96c43 (patch)
treee523d554d3df9ef3f05df71e155d3bd54e0dccb1 /target
parent57d6e7314381cdf8204597a3766c1d27051b4a2f (diff)
downloadupstream-4834d09a3f91622bb78e2163181a976933a96c43.tar.gz
upstream-4834d09a3f91622bb78e2163181a976933a96c43.tar.bz2
upstream-4834d09a3f91622bb78e2163181a976933a96c43.zip
fixes none-pci build
SVN-Revision: 35062
Diffstat (limited to 'target')
-rw-r--r--target/linux/lantiq/patches-3.7/0302-wifi-eep.patch5
-rw-r--r--target/linux/lantiq/patches-3.7/0303-vmmc.patch17
2 files changed, 12 insertions, 10 deletions
diff --git a/target/linux/lantiq/patches-3.7/0302-wifi-eep.patch b/target/linux/lantiq/patches-3.7/0302-wifi-eep.patch
index 65ec0d17b6..54a8acd1ed 100644
--- a/target/linux/lantiq/patches-3.7/0302-wifi-eep.patch
+++ b/target/linux/lantiq/patches-3.7/0302-wifi-eep.patch
@@ -2,10 +2,11 @@ Index: linux-3.7-rc8/arch/mips/lantiq/xway/Makefile
===================================================================
--- linux-3.7-rc8.orig/arch/mips/lantiq/xway/Makefile 2012-12-13 10:59:54.176314899 +0100
+++ linux-3.7-rc8/arch/mips/lantiq/xway/Makefile 2012-12-13 13:58:51.696584083 +0100
-@@ -1,3 +1,5 @@
+@@ -1,3 +1,6 @@
obj-y := prom.o sysctrl.o clk.o reset.o dma.o timer.o dcdc.o
-+obj-y += ath_eep.o rt_eep.o eth_mac.o
++obj-y += eth_mac.o
++obj-$(CONFIG_PCI) += ath_eep.o rt_eep.o
+
obj-$(CONFIG_XRX200_PHY_FW) += xrx200_phy_fw.o
Index: linux-3.7-rc8/arch/mips/lantiq/xway/ath_eep.c
diff --git a/target/linux/lantiq/patches-3.7/0303-vmmc.patch b/target/linux/lantiq/patches-3.7/0303-vmmc.patch
index f0bd584e38..4b5c280e82 100644
--- a/target/linux/lantiq/patches-3.7/0303-vmmc.patch
+++ b/target/linux/lantiq/patches-3.7/0303-vmmc.patch
@@ -1,18 +1,19 @@
-Index: linux-3.7-rc8/arch/mips/lantiq/xway/Makefile
+Index: linux-3.7.1/arch/mips/lantiq/xway/Makefile
===================================================================
---- linux-3.7-rc8.orig/arch/mips/lantiq/xway/Makefile 2012-12-13 13:40:23.000000000 +0100
-+++ linux-3.7-rc8/arch/mips/lantiq/xway/Makefile 2012-12-13 13:40:49.788556963 +0100
-@@ -1,5 +1,5 @@
+--- linux-3.7.1.orig/arch/mips/lantiq/xway/Makefile 2013-01-09 09:30:35.000000000 +0100
++++ linux-3.7.1/arch/mips/lantiq/xway/Makefile 2013-01-09 09:33:03.932167465 +0100
+@@ -1,6 +1,6 @@
obj-y := prom.o sysctrl.o clk.o reset.o dma.o timer.o dcdc.o
--obj-y += ath_eep.o rt_eep.o eth_mac.o
-+obj-y += ath_eep.o rt_eep.o eth_mac.o vmmc.o
+-obj-y += eth_mac.o
++obj-y += eth_mac.o vmmc.o
+ obj-$(CONFIG_PCI) += ath_eep.o rt_eep.o
obj-$(CONFIG_XRX200_PHY_FW) += xrx200_phy_fw.o
-Index: linux-3.7-rc8/arch/mips/lantiq/xway/vmmc.c
+Index: linux-3.7.1/arch/mips/lantiq/xway/vmmc.c
===================================================================
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
-+++ linux-3.7-rc8/arch/mips/lantiq/xway/vmmc.c 2012-12-13 13:40:30.520556476 +0100
++++ linux-3.7.1/arch/mips/lantiq/xway/vmmc.c 2013-01-09 09:31:49.264164272 +0100
@@ -0,0 +1,63 @@
+/*
+ * This program is free software; you can redistribute it and/or modify it