aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorPeter Denison <openwrt@marshadder.org>2009-01-12 20:36:50 +0000
committerPeter Denison <openwrt@marshadder.org>2009-01-12 20:36:50 +0000
commit5e4c1b348953cb943bdbbe931603fd4bb0da48c3 (patch)
tree0ceb00519fa088cb6c22f5f9d6897b37efdd1d1f /target
parent2c1d444866fc630b700ee6c9f805749f8df5a544 (diff)
downloadupstream-5e4c1b348953cb943bdbbe931603fd4bb0da48c3.tar.gz
upstream-5e4c1b348953cb943bdbbe931603fd4bb0da48c3.tar.bz2
upstream-5e4c1b348953cb943bdbbe931603fd4bb0da48c3.zip
Correct 2.6..26 and .28 versions of USR8200 patches
SVN-Revision: 13996
Diffstat (limited to 'target')
-rw-r--r--target/linux/ixp4xx/patches-2.6.26/500-usr8200_support.patch12
-rw-r--r--target/linux/ixp4xx/patches-2.6.26/501-cachetypes.patch4
-rw-r--r--target/linux/ixp4xx/patches-2.6.28/501-cachetypes.patch20
3 files changed, 8 insertions, 28 deletions
diff --git a/target/linux/ixp4xx/patches-2.6.26/500-usr8200_support.patch b/target/linux/ixp4xx/patches-2.6.26/500-usr8200_support.patch
index ef818c7ca0..365eb6a404 100644
--- a/target/linux/ixp4xx/patches-2.6.26/500-usr8200_support.patch
+++ b/target/linux/ixp4xx/patches-2.6.26/500-usr8200_support.patch
@@ -17,18 +17,18 @@
select PCI
--- a/arch/arm/mach-ixp4xx/Makefile
+++ b/arch/arm/mach-ixp4xx/Makefile
-@@ -25,6 +25,7 @@ obj-pci-$(CONFIG_MACH_WRT300NV2) += wrt
+@@ -24,6 +24,7 @@ obj-pci-$(CONFIG_MACH_COMPEX) += ixdp42
+ obj-pci-$(CONFIG_MACH_WRT300NV2) += wrt300nv2-pci.o
obj-pci-$(CONFIG_MACH_AP1000) += ixdp425-pci.o
obj-pci-$(CONFIG_MACH_TW5334) += tw5334-pci.o
- obj-pci-$(CONFIG_MACH_MI424WR) += mi424wr-pci.o
+obj-pci-$(CONFIG_MACH_USR8200) += usr8200-pci.o
obj-y += common.o
-@@ -48,6 +49,7 @@ obj-$(CONFIG_MACH_WRT300NV2) += wrt300nv
+@@ -46,6 +47,7 @@ obj-$(CONFIG_MACH_COMPEX) += compex-setu
+ obj-$(CONFIG_MACH_WRT300NV2) += wrt300nv2-setup.o
obj-$(CONFIG_MACH_AP1000) += ap1000-setup.o
obj-$(CONFIG_MACH_TW5334) += tw5334-setup.o
- obj-$(CONFIG_MACH_MI424WR) += mi424wr-setup.o
+obj-$(CONFIG_MACH_USR8200) += usr8200-setup.o
obj-$(CONFIG_PCI) += $(obj-pci-$(CONFIG_PCI)) common-pci.o
@@ -328,8 +328,8 @@
+ .boot_params = 0x0100,
+ .init_machine = usr8200_init,
+MACHINE_END
---- a/arch/arm/mach-ixp4xx/include/mach/uncompress.h
-+++ b/arch/arm/mach-ixp4xx/include/mach/uncompress.h
+--- a/include/asm-arm/arch-ixp4xx/uncompress.h
++++ b/include/asm-arm/arch-ixp4xx/uncompress.h
@@ -43,7 +43,7 @@ static __inline__ void __arch_decomp_set
if (machine_is_adi_coyote() || machine_is_gtwx5715() ||
machine_is_gateway7001() || machine_is_wg302v2() ||
diff --git a/target/linux/ixp4xx/patches-2.6.26/501-cachetypes.patch b/target/linux/ixp4xx/patches-2.6.26/501-cachetypes.patch
index cc9c89e3e1..5f5c443596 100644
--- a/target/linux/ixp4xx/patches-2.6.26/501-cachetypes.patch
+++ b/target/linux/ixp4xx/patches-2.6.26/501-cachetypes.patch
@@ -1,6 +1,6 @@
--- a/arch/arm/kernel/setup.c
+++ b/arch/arm/kernel/setup.c
-@@ -184,7 +184,7 @@ static const char *cache_types[16] = {
+@@ -181,7 +181,7 @@ static const char *cache_types[16] = {
"write-back",
"undefined 3",
"undefined 4",
@@ -9,7 +9,7 @@
"write-back",
"write-back",
"undefined 8",
-@@ -203,7 +203,7 @@ static const char *cache_clean[16] = {
+@@ -200,7 +200,7 @@ static const char *cache_clean[16] = {
"cp15 c7 ops",
"undefined 3",
"undefined 4",
diff --git a/target/linux/ixp4xx/patches-2.6.28/501-cachetypes.patch b/target/linux/ixp4xx/patches-2.6.28/501-cachetypes.patch
deleted file mode 100644
index cc9c89e3e1..0000000000
--- a/target/linux/ixp4xx/patches-2.6.28/501-cachetypes.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- a/arch/arm/kernel/setup.c
-+++ b/arch/arm/kernel/setup.c
-@@ -184,7 +184,7 @@ static const char *cache_types[16] = {
- "write-back",
- "undefined 3",
- "undefined 4",
-- "undefined 5",
-+ "write-back",
- "write-back",
- "write-back",
- "undefined 8",
-@@ -203,7 +203,7 @@ static const char *cache_clean[16] = {
- "cp15 c7 ops",
- "undefined 3",
- "undefined 4",
-- "undefined 5",
-+ "cp15 c7 ops",
- "cp15 c7 ops",
- "cp15 c7 ops",
- "undefined 8",