aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-07-28 10:23:38 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-07-28 10:23:38 +0000
commit65584ed54fbcc026b59f437bfd19d8227d7e740a (patch)
tree131602152998a95fdef8720b4dfb024c0e3cce7c /target
parent41d136f2c88e70aea3c9c536ff7361b4e181c6b9 (diff)
downloadupstream-65584ed54fbcc026b59f437bfd19d8227d7e740a.tar.gz
upstream-65584ed54fbcc026b59f437bfd19d8227d7e740a.tar.bz2
upstream-65584ed54fbcc026b59f437bfd19d8227d7e740a.zip
ar71xx: add profile and build image for the WNR612 v2 board
Signed-off-by: Cezary Jackiewicz <cezary.jackiewicz@gmail.com> Patchwork: http://patchwork.openwrt.org/patch/3876/ Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 37577
Diffstat (limited to 'target')
-rw-r--r--target/linux/ar71xx/generic/profiles/netgear.mk10
-rw-r--r--target/linux/ar71xx/image/Makefile1
2 files changed, 11 insertions, 0 deletions
diff --git a/target/linux/ar71xx/generic/profiles/netgear.mk b/target/linux/ar71xx/generic/profiles/netgear.mk
index 15a20813d0..99425ec106 100644
--- a/target/linux/ar71xx/generic/profiles/netgear.mk
+++ b/target/linux/ar71xx/generic/profiles/netgear.mk
@@ -50,3 +50,13 @@ endef
$(eval $(call Profile,WNR2000V3))
+
+define Profile/WNR612V2
+ NAME:=NETGEAR WNR612V2
+endef
+
+define Profile/WNR612V2/Description
+ Package set optimized for the NETGEAR WNR612V2
+endef
+
+$(eval $(call Profile,WNR612V2))
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 4b7da17b47..a9f1f9e5a0 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -922,6 +922,7 @@ $(eval $(call SingleProfile,MyLoader,$(fs_64k),WPE72_16M,wpe72,,ttyS0,115200,0x1
# This is used with AthGzip profile for now
$(eval $(call SingleProfile,AthGzip,$(fs_64k),WNDAP360,wndap360,WNDAP360,ttyS0,9600,$$(wndap360_mtdlayout),1769472,6160384,KRuImage))
$(eval $(call SingleProfile,Netgear,$(fs_64k),WNR2000V3,wnr2000v3,WNR2000V3,ttyS0,115200,$$(wnr2000v3_mtdlayout),2003,WNR2000V3,"" NA,))
+$(eval $(call SingleProfile,Netgear,$(fs_64k),WNR612V2,wnr612v2,WNR612V2,ttyS0,115200,$$(wnr2000v3_mtdlayout),2061,WNR612V2,"",))
$(eval $(call SingleProfile,Netgear,$(fs_64k),WNDR3700V1,wndr3700,WNDR3700,ttyS0,115200,$$(wndr3700_mtdlayout),3700,WNDR3700,"" NA,))
$(eval $(call SingleProfile,Netgear,$(fs_64k),WNDR3700V2,wndr3700v2,WNDR3700,ttyS0,115200,$$(wndr3700v2_mtdlayout),3701,WNDR3700v2,"",-H 29763654+16+64))
$(eval $(call SingleProfile,Netgear,$(fs_64k),WNDR3800,wndr3800,WNDR3700,ttyS0,115200,$$(wndr3700v2_mtdlayout),3701,WNDR3800,"",-H 29763654+16+128))