aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-07-15 18:41:57 +0200
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-07-15 18:41:57 +0200
commit9f3415d30bda1cdeef484d6f179f70d95295c9e2 (patch)
treea4f4a6e23d2532faad53b1de1c828f45fa70a7b6 /target
parente49fac097ca738658bf33fd918437bfec3e6ed80 (diff)
downloadupstream-9f3415d30bda1cdeef484d6f179f70d95295c9e2.tar.gz
upstream-9f3415d30bda1cdeef484d6f179f70d95295c9e2.tar.bz2
upstream-9f3415d30bda1cdeef484d6f179f70d95295c9e2.zip
ath79: harmonize model names for Ubiquiti devices
This harmonizes the model names for the ath79 Ubiquiti devices by applying a few minor cosmetic adjustments: - Removes hyphens where they are not found in the product names (Ubiquiti uses hyphens only for the abbreviated version names like UAP-AC-PRO which we don't use anyway.) - Add (XM) suffix for DTS model strings to help with distinguishing them from their XW counterparts. - Remove DEVICE_VARIANT for LAP-120 which actually was an alternate device name. - Generally make DTS model names and those from generic-ubnt.mk more consistent. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target')
-rw-r--r--target/linux/ath79/dts/ar7161_ubnt_routerstation.dts2
-rw-r--r--target/linux/ath79/dts/ar7240_ubnt_bullet-m-ar7240.dts2
-rw-r--r--target/linux/ath79/dts/ar7241_ubnt_airrouter.dts2
-rw-r--r--target/linux/ath79/dts/ar7241_ubnt_bullet-m-ar7241.dts2
-rw-r--r--target/linux/ath79/dts/ar7241_ubnt_nanobridge-m.dts2
-rw-r--r--target/linux/ath79/dts/ar7241_ubnt_nanostation-loco-m.dts2
-rw-r--r--target/linux/ath79/dts/ar7241_ubnt_nanostation-m.dts2
-rw-r--r--target/linux/ath79/dts/ar7241_ubnt_picostation-m.dts2
-rw-r--r--target/linux/ath79/dts/ar7241_ubnt_powerbridge-m.dts2
-rw-r--r--target/linux/ath79/dts/ar7241_ubnt_rocket-m.dts2
-rw-r--r--target/linux/ath79/dts/ar7241_ubnt_unifi.dts2
-rw-r--r--target/linux/ath79/dts/qca9563_ubnt_unifiac-lite.dts2
-rw-r--r--target/linux/ath79/dts/qca9563_ubnt_unifiac-lr.dts2
-rw-r--r--target/linux/ath79/dts/qca9563_ubnt_unifiac-mesh-pro.dts2
-rw-r--r--target/linux/ath79/dts/qca9563_ubnt_unifiac-mesh.dts2
-rw-r--r--target/linux/ath79/dts/qca9563_ubnt_unifiac-pro.dts2
-rw-r--r--target/linux/ath79/image/generic-ubnt.mk21
17 files changed, 26 insertions, 27 deletions
diff --git a/target/linux/ath79/dts/ar7161_ubnt_routerstation.dts b/target/linux/ath79/dts/ar7161_ubnt_routerstation.dts
index 63b46b9c79..d3e6315306 100644
--- a/target/linux/ath79/dts/ar7161_ubnt_routerstation.dts
+++ b/target/linux/ath79/dts/ar7161_ubnt_routerstation.dts
@@ -5,7 +5,7 @@
/ {
compatible = "ubnt,routerstation", "qca,ar7161";
- model = "Ubiquiti Networks RouterStation";
+ model = "Ubiquiti RouterStation";
};
&eth0 {
diff --git a/target/linux/ath79/dts/ar7240_ubnt_bullet-m-ar7240.dts b/target/linux/ath79/dts/ar7240_ubnt_bullet-m-ar7240.dts
index 58b35f5c8b..73626f1ff4 100644
--- a/target/linux/ath79/dts/ar7240_ubnt_bullet-m-ar7240.dts
+++ b/target/linux/ath79/dts/ar7240_ubnt_bullet-m-ar7240.dts
@@ -7,7 +7,7 @@
/ {
compatible = "ubnt,bullet-m-ar7240", "ubnt,xm", "qca,ar7240";
- model = "Ubiquiti Bullet M XM (AR7240)";
+ model = "Ubiquiti Bullet M (XM AR7240)";
};
&eth0 {
diff --git a/target/linux/ath79/dts/ar7241_ubnt_airrouter.dts b/target/linux/ath79/dts/ar7241_ubnt_airrouter.dts
index dd2421da8e..9da1c45b47 100644
--- a/target/linux/ath79/dts/ar7241_ubnt_airrouter.dts
+++ b/target/linux/ath79/dts/ar7241_ubnt_airrouter.dts
@@ -6,7 +6,7 @@
/ {
compatible = "ubnt,airrouter", "ubnt,xm", "qca,ar7241";
- model = "Ubiquiti AirRouter";
+ model = "Ubiquiti AirRouter (XM)";
aliases {
led-boot = &led_globe;
diff --git a/target/linux/ath79/dts/ar7241_ubnt_bullet-m-ar7241.dts b/target/linux/ath79/dts/ar7241_ubnt_bullet-m-ar7241.dts
index 0e2183c27d..261ee5435e 100644
--- a/target/linux/ath79/dts/ar7241_ubnt_bullet-m-ar7241.dts
+++ b/target/linux/ath79/dts/ar7241_ubnt_bullet-m-ar7241.dts
@@ -7,7 +7,7 @@
/ {
compatible = "ubnt,bullet-m-ar7241", "ubnt,xm", "qca,ar7241";
- model = "Ubiquiti Bullet M XM (AR7241)";
+ model = "Ubiquiti Bullet M (XM AR7241)";
};
&eth1 {
diff --git a/target/linux/ath79/dts/ar7241_ubnt_nanobridge-m.dts b/target/linux/ath79/dts/ar7241_ubnt_nanobridge-m.dts
index 005ef27caa..4c4fd19d32 100644
--- a/target/linux/ath79/dts/ar7241_ubnt_nanobridge-m.dts
+++ b/target/linux/ath79/dts/ar7241_ubnt_nanobridge-m.dts
@@ -7,7 +7,7 @@
/ {
compatible = "ubnt,nanobridge-m", "ubnt,xm", "qca,ar7241";
- model = "Ubiquiti NanoBridge M";
+ model = "Ubiquiti NanoBridge M (XM)";
};
&eth1 {
diff --git a/target/linux/ath79/dts/ar7241_ubnt_nanostation-loco-m.dts b/target/linux/ath79/dts/ar7241_ubnt_nanostation-loco-m.dts
index 60d5a21a22..4ccb1d50a7 100644
--- a/target/linux/ath79/dts/ar7241_ubnt_nanostation-loco-m.dts
+++ b/target/linux/ath79/dts/ar7241_ubnt_nanostation-loco-m.dts
@@ -7,7 +7,7 @@
/ {
compatible = "ubnt,nanostation-loco-m", "ubnt,xm", "qca,ar7241";
- model = "Ubiquiti Nanostation Loco M";
+ model = "Ubiquiti Nanostation Loco M (XM)";
};
&eth1 {
diff --git a/target/linux/ath79/dts/ar7241_ubnt_nanostation-m.dts b/target/linux/ath79/dts/ar7241_ubnt_nanostation-m.dts
index 82344bb5ea..fff4ec7042 100644
--- a/target/linux/ath79/dts/ar7241_ubnt_nanostation-m.dts
+++ b/target/linux/ath79/dts/ar7241_ubnt_nanostation-m.dts
@@ -7,5 +7,5 @@
/ {
compatible = "ubnt,nanostation-m", "ubnt,xm", "qca,ar7241";
- model = "Ubiquiti Nanostation M";
+ model = "Ubiquiti Nanostation M (XM)";
};
diff --git a/target/linux/ath79/dts/ar7241_ubnt_picostation-m.dts b/target/linux/ath79/dts/ar7241_ubnt_picostation-m.dts
index d05aca3e67..4bb13e618c 100644
--- a/target/linux/ath79/dts/ar7241_ubnt_picostation-m.dts
+++ b/target/linux/ath79/dts/ar7241_ubnt_picostation-m.dts
@@ -7,7 +7,7 @@
/ {
compatible = "ubnt,picostation-m", "ubnt,xm", "qca,ar7241";
- model = "Ubiquiti Picostation M";
+ model = "Ubiquiti Picostation M (XM)";
};
&eth1 {
diff --git a/target/linux/ath79/dts/ar7241_ubnt_powerbridge-m.dts b/target/linux/ath79/dts/ar7241_ubnt_powerbridge-m.dts
index 3bf9ca4a90..e14bfbfa8d 100644
--- a/target/linux/ath79/dts/ar7241_ubnt_powerbridge-m.dts
+++ b/target/linux/ath79/dts/ar7241_ubnt_powerbridge-m.dts
@@ -7,7 +7,7 @@
/ {
compatible = "ubnt,powerbridge-m", "ubnt,xm", "qca,ar7241";
- model = "Ubiquiti PowerBridge M";
+ model = "Ubiquiti PowerBridge M (XM)";
};
&eth1 {
diff --git a/target/linux/ath79/dts/ar7241_ubnt_rocket-m.dts b/target/linux/ath79/dts/ar7241_ubnt_rocket-m.dts
index 9e342177e2..3e716dec6c 100644
--- a/target/linux/ath79/dts/ar7241_ubnt_rocket-m.dts
+++ b/target/linux/ath79/dts/ar7241_ubnt_rocket-m.dts
@@ -7,7 +7,7 @@
/ {
compatible = "ubnt,rocket-m", "ubnt,xm", "qca,ar7241";
- model = "Ubiquiti Rocket M";
+ model = "Ubiquiti Rocket M (XM)";
};
&eth1 {
diff --git a/target/linux/ath79/dts/ar7241_ubnt_unifi.dts b/target/linux/ath79/dts/ar7241_ubnt_unifi.dts
index 5f12fd581b..e7369f0dbf 100644
--- a/target/linux/ath79/dts/ar7241_ubnt_unifi.dts
+++ b/target/linux/ath79/dts/ar7241_ubnt_unifi.dts
@@ -8,7 +8,7 @@
/ {
compatible = "ubnt,unifi", "qca,ar7241";
- model = "Ubiquiti UniFi AP";
+ model = "Ubiquiti UniFi";
aliases {
led-boot = &led_dome_green;
diff --git a/target/linux/ath79/dts/qca9563_ubnt_unifiac-lite.dts b/target/linux/ath79/dts/qca9563_ubnt_unifiac-lite.dts
index 7b9fa0701b..4ab4197a87 100644
--- a/target/linux/ath79/dts/qca9563_ubnt_unifiac-lite.dts
+++ b/target/linux/ath79/dts/qca9563_ubnt_unifiac-lite.dts
@@ -5,5 +5,5 @@
/ {
compatible = "ubnt,unifiac-lite", "qca,qca9563";
- model = "Ubiquiti UniFi-AC-LITE";
+ model = "Ubiquiti UniFi AC Lite";
};
diff --git a/target/linux/ath79/dts/qca9563_ubnt_unifiac-lr.dts b/target/linux/ath79/dts/qca9563_ubnt_unifiac-lr.dts
index a1e542ada6..3128081b55 100644
--- a/target/linux/ath79/dts/qca9563_ubnt_unifiac-lr.dts
+++ b/target/linux/ath79/dts/qca9563_ubnt_unifiac-lr.dts
@@ -5,5 +5,5 @@
/ {
compatible = "ubnt,unifiac-lr", "qca,qca9563";
- model = "Ubiquiti UniFi-AC-LR";
+ model = "Ubiquiti UniFi AC LR";
};
diff --git a/target/linux/ath79/dts/qca9563_ubnt_unifiac-mesh-pro.dts b/target/linux/ath79/dts/qca9563_ubnt_unifiac-mesh-pro.dts
index 9d80217d4e..97d9763049 100644
--- a/target/linux/ath79/dts/qca9563_ubnt_unifiac-mesh-pro.dts
+++ b/target/linux/ath79/dts/qca9563_ubnt_unifiac-mesh-pro.dts
@@ -5,5 +5,5 @@
/ {
compatible = "ubnt,unifiac-mesh-pro", "qca,qca9563";
- model = "Ubiquiti UniFi-AC-MESH PRO";
+ model = "Ubiquiti UniFi AC Mesh Pro";
};
diff --git a/target/linux/ath79/dts/qca9563_ubnt_unifiac-mesh.dts b/target/linux/ath79/dts/qca9563_ubnt_unifiac-mesh.dts
index 6eed56bb6c..b3d652bdfa 100644
--- a/target/linux/ath79/dts/qca9563_ubnt_unifiac-mesh.dts
+++ b/target/linux/ath79/dts/qca9563_ubnt_unifiac-mesh.dts
@@ -5,5 +5,5 @@
/ {
compatible = "ubnt,unifiac-mesh", "qca,qca9563";
- model = "Ubiquiti UniFi-AC-MESH";
+ model = "Ubiquiti UniFi AC Mesh";
};
diff --git a/target/linux/ath79/dts/qca9563_ubnt_unifiac-pro.dts b/target/linux/ath79/dts/qca9563_ubnt_unifiac-pro.dts
index 41449bbfc3..48c9e105e2 100644
--- a/target/linux/ath79/dts/qca9563_ubnt_unifiac-pro.dts
+++ b/target/linux/ath79/dts/qca9563_ubnt_unifiac-pro.dts
@@ -5,7 +5,7 @@
/ {
compatible = "ubnt,unifiac-pro", "qca,qca9563";
- model = "Ubiquiti UniFi-AC-PRO";
+ model = "Ubiquiti UniFi AC Pro";
};
&usb_phy0 {
diff --git a/target/linux/ath79/image/generic-ubnt.mk b/target/linux/ath79/image/generic-ubnt.mk
index e9202eadf7..55d98ce508 100644
--- a/target/linux/ath79/image/generic-ubnt.mk
+++ b/target/linux/ath79/image/generic-ubnt.mk
@@ -125,7 +125,7 @@ TARGET_DEVICES += ubnt_airrouter
define Device/ubnt_bullet-m-ar7240
$(Device/ubnt-xm)
SOC := ar7240
- DEVICE_MODEL := Bullet-M
+ DEVICE_MODEL := Bullet M
DEVICE_VARIANT := XM (AR7240)
DEVICE_PACKAGES += rssileds
SUPPORTED_DEVICES += bullet-m
@@ -135,7 +135,7 @@ TARGET_DEVICES += ubnt_bullet-m-ar7240
define Device/ubnt_bullet-m-ar7241
$(Device/ubnt-xm)
SOC := ar7241
- DEVICE_MODEL := Bullet-M
+ DEVICE_MODEL := Bullet M
DEVICE_VARIANT := XM (AR7241)
DEVICE_PACKAGES += rssileds
SUPPORTED_DEVICES += bullet-m ubnt,bullet-m
@@ -144,7 +144,7 @@ TARGET_DEVICES += ubnt_bullet-m-ar7241
define Device/ubnt_bullet-m-xw
$(Device/ubnt-xw)
- DEVICE_MODEL := Bullet-M
+ DEVICE_MODEL := Bullet M
DEVICE_PACKAGES += rssileds
SUPPORTED_DEVICES += bullet-m-xw
endef
@@ -165,8 +165,7 @@ TARGET_DEVICES += ubnt_edgeswitch-8xp
define Device/ubnt_lap-120
$(Device/ubnt-wa)
- DEVICE_MODEL := LiteAP ac
- DEVICE_VARIANT := LAP-120
+ DEVICE_MODEL := LiteAP ac (LAP-120)
DEVICE_PACKAGES += kmod-ath10k-ct-smallbuffers ath10k-firmware-qca988x-ct
endef
TARGET_DEVICES += ubnt_lap-120
@@ -281,7 +280,7 @@ TARGET_DEVICES += ubnt_powerbridge-m
define Device/ubnt_rocket-m
$(Device/ubnt-xm)
SOC := ar7241
- DEVICE_MODEL := Rocket-M
+ DEVICE_MODEL := Rocket M
DEVICE_PACKAGES += rssileds
SUPPORTED_DEVICES += rocket-m
endef
@@ -337,35 +336,35 @@ endef
define Device/ubnt_unifiac-lite
$(Device/ubnt_unifiac)
- DEVICE_MODEL := UniFi AC-Lite
+ DEVICE_MODEL := UniFi AC Lite
SUPPORTED_DEVICES += unifiac-lite
endef
TARGET_DEVICES += ubnt_unifiac-lite
define Device/ubnt_unifiac-lr
$(Device/ubnt_unifiac)
- DEVICE_MODEL := UniFi AC-LR
+ DEVICE_MODEL := UniFi AC LR
SUPPORTED_DEVICES += unifiac-lite ubnt,unifiac-lite
endef
TARGET_DEVICES += ubnt_unifiac-lr
define Device/ubnt_unifiac-mesh
$(Device/ubnt_unifiac)
- DEVICE_MODEL := UniFi AC-Mesh
+ DEVICE_MODEL := UniFi AC Mesh
SUPPORTED_DEVICES += unifiac-lite
endef
TARGET_DEVICES += ubnt_unifiac-mesh
define Device/ubnt_unifiac-mesh-pro
$(Device/ubnt_unifiac)
- DEVICE_MODEL := UniFi AC-Mesh Pro
+ DEVICE_MODEL := UniFi AC Mesh Pro
SUPPORTED_DEVICES += unifiac-pro
endef
TARGET_DEVICES += ubnt_unifiac-mesh-pro
define Device/ubnt_unifiac-pro
$(Device/ubnt_unifiac)
- DEVICE_MODEL := UniFi AC-Pro
+ DEVICE_MODEL := UniFi AC Pro
DEVICE_PACKAGES += kmod-usb2
SUPPORTED_DEVICES += unifiac-pro
endef