aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorPiotr Dymacz <pepe2k@gmail.com>2017-05-30 23:20:16 +0200
committerPiotr Dymacz <pepe2k@gmail.com>2017-06-11 19:06:49 +0200
commitaf27dd1a51d0aa093e36971eafef4cbc9e1e01c3 (patch)
tree9af23c82888c5f2470cd2038011ce832caa75300 /target
parent43c0ef10100e4c9d583c10f24341c422df20b0cd (diff)
downloadupstream-af27dd1a51d0aa093e36971eafef4cbc9e1e01c3.tar.gz
upstream-af27dd1a51d0aa093e36971eafef4cbc9e1e01c3.tar.bz2
upstream-af27dd1a51d0aa093e36971eafef4cbc9e1e01c3.zip
ar71xx: image: simplify Compex devices definitions
Signed-off-by: Piotr Dymacz <pepe2k@gmail.com>
Diffstat (limited to 'target')
-rw-r--r--target/linux/ar71xx/image/generic.mk32
1 files changed, 12 insertions, 20 deletions
diff --git a/target/linux/ar71xx/image/generic.mk b/target/linux/ar71xx/image/generic.mk
index 27c6b4e50f..cf1b7d10d7 100644
--- a/target/linux/ar71xx/image/generic.mk
+++ b/target/linux/ar71xx/image/generic.mk
@@ -796,50 +796,42 @@ define Device/bhr-4grv2
endef
TARGET_DEVICES += bhr-4grv2
-define Device/wpj342
- DEVICE_TITLE := Compex WPJ342 (16MB flash)
+define Device/wpj-16m
DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-usb-ledtrig-usbport
- BOARDNAME := WPJ342
MTDPARTS := spi0.0:192k(u-boot)ro,16128k(firmware),64k(art)ro
IMAGE_SIZE := 16128k
endef
-TARGET_DEVICES += wpj342
+
+define Device/wpj342
+ $(Device/wpj-16m)
+ DEVICE_TITLE := Compex WPJ342 (16MB flash)
+ BOARDNAME := WPJ342
+endef
define Device/wpj344
+ $(Device/wpj-16m)
DEVICE_TITLE := Compex WPJ344 (16MB flash)
- DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-usb-ledtrig-usbport
BOARDNAME := WPJ344
- MTDPARTS := spi0.0:192k(u-boot)ro,16128k(firmware),64k(art)ro
- IMAGE_SIZE := 16128k
endef
-TARGET_DEVICES += wpj344
define Device/wpj531
+ $(Device/wpj-16m)
DEVICE_TITLE := Compex WPJ531 (16MB flash)
- DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-usb-ledtrig-usbport
BOARDNAME := WPJ531
- MTDPARTS := spi0.0:192k(u-boot)ro,16128k(firmware),64k(art)ro
- IMAGE_SIZE := 16128k
endef
-TARGET_DEVICES += wpj531
define Device/wpj558
+ $(Device/wpj-16m)
DEVICE_TITLE := Compex WPJ558 (16MB flash)
- DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-usb-ledtrig-usbport
BOARDNAME := WPJ558
- MTDPARTS := spi0.0:192k(u-boot)ro,16128k(firmware),64k(art)ro
- IMAGE_SIZE := 16128k
endef
-TARGET_DEVICES += wpj558
define Device/wpj563
+ $(Device/wpj-16m)
DEVICE_TITLE := Compex WPJ563 (16MB flash)
- DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-usb-ledtrig-usbport
BOARDNAME := WPJ563
- MTDPARTS := spi0.0:192k(u-boot)ro,16128k(firmware),64k(art)ro
- IMAGE_SIZE := 16128k
endef
-TARGET_DEVICES += wpj563
+TARGET_DEVICES += wpj342 wpj344 wpj531 wpj558 wpj563
define Device/zbt-we1526
DEVICE_TITLE := Zbtlink ZBT-WE1526