aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorPiotr Dymacz <pepe2k@gmail.com>2017-12-28 11:07:54 +0100
committerPiotr Dymacz <pepe2k@gmail.com>2018-01-15 00:12:13 +0100
commitaf8f0629df080bb057dea6cc77a1faacc648ae0d (patch)
tree2e2d903e580e1ba2af7b2f37bb96c17112678537 /target
parent1f06144cdec1487122201faa9350825ed565d99c (diff)
downloadupstream-af8f0629df080bb057dea6cc77a1faacc648ae0d.tar.gz
upstream-af8f0629df080bb057dea6cc77a1faacc648ae0d.tar.bz2
upstream-af8f0629df080bb057dea6cc77a1faacc648ae0d.zip
ar71xx: add support for ALFA Network R36A
ALFA Network R36A is a successor of the previous model, the R36 (Ralink RT3050F based). New version is based on Qualcomm/Atheros QCA9531 v2. Specification: - 650/400/200 MHz (CPU/DDR/AHB) - 64 MB of RAM (DDR2) - 16 MB of FLASH (SPI NOR) - 2x 10/100 Mbps Ethernet, with passive PoE support (24 V) - 2T2R (QCA9531) 2.4 GHz, 2x u.fl connectors on PCB - 1x USB 2.0 (power controlled by GPIO) - 6x LED (5 of them are driven by GPIO) - 2x button (reset, wifi/wps) - external h/w watchdog (EM6324QYSP5B, disabled and not used) - DC jack for main power input (12 V) - UART header on PCB Flash instruction: You can use sysupgrade image directly in vendor firmware which is based on LEDE/OpenWrt. Alternatively, you can use web recovery mode in U-Boot: 1. Configure PC with static IP 192.168.1.2/24. 2. Connect PC with one of RJ45 ports, press the reset button, power up device, wait for first blink of all LEDs (indicates network setup), then keep button for 3 following blinks and release it. 3. Open 192.168.1.1 address in your browser and upload sysupgrade image. Signed-off-by: Piotr Dymacz <pepe2k@gmail.com>
Diffstat (limited to 'target')
-rwxr-xr-xtarget/linux/ar71xx/base-files/etc/board.d/01_leds6
-rw-r--r--target/linux/ar71xx/base-files/etc/diag.sh3
-rwxr-xr-xtarget/linux/ar71xx/base-files/lib/ar71xx.sh3
-rwxr-xr-xtarget/linux/ar71xx/base-files/lib/upgrade/platform.sh1
-rw-r--r--target/linux/ar71xx/config-4.41
-rw-r--r--target/linux/ar71xx/config-4.91
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt10
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/Makefile1
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/mach-r36a.c140
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/machtypes.h1
-rw-r--r--target/linux/ar71xx/generic/config-default1
-rw-r--r--target/linux/ar71xx/image/generic.mk12
12 files changed, 179 insertions, 1 deletions
diff --git a/target/linux/ar71xx/base-files/etc/board.d/01_leds b/target/linux/ar71xx/base-files/etc/board.d/01_leds
index 02f3ad911a..f39109af44 100755
--- a/target/linux/ar71xx/base-files/etc/board.d/01_leds
+++ b/target/linux/ar71xx/base-files/etc/board.d/01_leds
@@ -580,6 +580,12 @@ pqi-air-pen)
qihoo-c301)
ucidef_set_led_wlan "wlan2g" "WLAN2G" "qihoo:red:status" "phy1tpt"
;;
+r36a)
+ ucidef_set_led_netdev "lan" "LAN" "$board:blue:lan" "eth0"
+ ucidef_set_led_usbdev "usb" "USB" "$board:blue:usb" "1-1"
+ ucidef_set_led_netdev "wan" "WAN" "$board:blue:wan" "eth1"
+ ucidef_set_led_wlan "wlan" "WLAN" "$board:blue:wlan" "phy0tpt"
+ ;;
r602n|\
zbt-we1526)
ucidef_set_led_netdev "wan" "WAN" "$board:green:wan" "eth1"
diff --git a/target/linux/ar71xx/base-files/etc/diag.sh b/target/linux/ar71xx/base-files/etc/diag.sh
index 1dece96f84..00ddeeac50 100644
--- a/target/linux/ar71xx/base-files/etc/diag.sh
+++ b/target/linux/ar71xx/base-files/etc/diag.sh
@@ -181,7 +181,8 @@ get_status_led() {
oolite)
status_led="$board:red:system"
;;
- dw33d)
+ dw33d|\
+ r36a)
status_led="$board:blue:status"
;;
eap300v2)
diff --git a/target/linux/ar71xx/base-files/lib/ar71xx.sh b/target/linux/ar71xx/base-files/lib/ar71xx.sh
index 1419579d83..d62dff593e 100755
--- a/target/linux/ar71xx/base-files/lib/ar71xx.sh
+++ b/target/linux/ar71xx/base-files/lib/ar71xx.sh
@@ -847,6 +847,9 @@ ar71xx_board_detect() {
*"Qihoo 360 C301")
name="qihoo-c301"
;;
+ *"R36A")
+ name="r36a"
+ ;;
*"R602N")
name="r602n"
;;
diff --git a/target/linux/ar71xx/base-files/lib/upgrade/platform.sh b/target/linux/ar71xx/base-files/lib/upgrade/platform.sh
index 86d0476790..108c90b1fe 100755
--- a/target/linux/ar71xx/base-files/lib/upgrade/platform.sh
+++ b/target/linux/ar71xx/base-files/lib/upgrade/platform.sh
@@ -257,6 +257,7 @@ platform_check_image() {
nanostation-m-xw|\
nbg460n_550n_550nh|\
pqi-air-pen|\
+ r36a|\
r602n|\
rocket-m|\
rocket-m-ti|\
diff --git a/target/linux/ar71xx/config-4.4 b/target/linux/ar71xx/config-4.4
index 1dc7127bfb..44303f1be0 100644
--- a/target/linux/ar71xx/config-4.4
+++ b/target/linux/ar71xx/config-4.4
@@ -153,6 +153,7 @@ CONFIG_ATH79=y
# CONFIG_ATH79_MACH_PB44 is not set
# CONFIG_ATH79_MACH_PQI_AIR_PEN is not set
# CONFIG_ATH79_MACH_QIHOO_C301 is not set
+# CONFIG_ATH79_MACH_R36A is not set
# CONFIG_ATH79_MACH_R602N is not set
# CONFIG_ATH79_MACH_R6100 is not set
# CONFIG_ATH79_MACH_RAMBUTAN is not set
diff --git a/target/linux/ar71xx/config-4.9 b/target/linux/ar71xx/config-4.9
index 78393b13f4..1e4b3ab87d 100644
--- a/target/linux/ar71xx/config-4.9
+++ b/target/linux/ar71xx/config-4.9
@@ -151,6 +151,7 @@ CONFIG_ATH79=y
# CONFIG_ATH79_MACH_PB44 is not set
# CONFIG_ATH79_MACH_PQI_AIR_PEN is not set
# CONFIG_ATH79_MACH_QIHOO_C301 is not set
+# CONFIG_ATH79_MACH_R36A is not set
# CONFIG_ATH79_MACH_R602N is not set
# CONFIG_ATH79_MACH_R6100 is not set
# CONFIG_ATH79_MACH_RAMBUTAN is not set
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt b/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt
index 2b7e086e2c..dae68d0fb7 100644
--- a/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt
+++ b/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt
@@ -934,6 +934,16 @@ config ATH79_MACH_WRTNODE2Q
select ATH79_DEV_M25P80
select ATH79_DEV_WMAC
+config ATH79_MACH_R36A
+ bool "ALFA Network R36A support"
+ select SOC_QCA953X
+ select ATH79_DEV_ETH
+ select ATH79_DEV_GPIO_BUTTONS
+ select ATH79_DEV_LEDS_GPIO
+ select ATH79_DEV_M25P80
+ select ATH79_DEV_USB
+ select ATH79_DEV_WMAC
+
config ATH79_MACH_R602N
bool "P&W R602N support"
select SOC_QCA953X
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/Makefile b/target/linux/ar71xx/files/arch/mips/ath79/Makefile
index 4f3bb97e33..b7caa5a770 100644
--- a/target/linux/ar71xx/files/arch/mips/ath79/Makefile
+++ b/target/linux/ar71xx/files/arch/mips/ath79/Makefile
@@ -162,6 +162,7 @@ obj-$(CONFIG_ATH79_MACH_PB42) += mach-pb42.o
obj-$(CONFIG_ATH79_MACH_PB44) += mach-pb44.o
obj-$(CONFIG_ATH79_MACH_PQI_AIR_PEN) += mach-pqi-air-pen.o
obj-$(CONFIG_ATH79_MACH_QIHOO_C301) += mach-qihoo-c301.o
+obj-$(CONFIG_ATH79_MACH_R36A) += mach-r36a.o
obj-$(CONFIG_ATH79_MACH_R602N) += mach-r602n.o
obj-$(CONFIG_ATH79_MACH_R6100) += mach-r6100.o
obj-$(CONFIG_ATH79_MACH_RB2011) += mach-rb2011.o
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/mach-r36a.c b/target/linux/ar71xx/files/arch/mips/ath79/mach-r36a.c
new file mode 100644
index 0000000000..b3493e2c42
--- /dev/null
+++ b/target/linux/ar71xx/files/arch/mips/ath79/mach-r36a.c
@@ -0,0 +1,140 @@
+/*
+ * ALFA Network R36A board support
+ *
+ * Copyright (C) 2018 Piotr Dymacz <pepe2k@gmail.com>
+ *
+ * This program is free software; you can redistribute it and/or modify it
+ * under the terms of the GNU General Public License version 2 as published
+ * by the Free Software Foundation.
+ */
+
+#include <linux/gpio.h>
+#include <linux/platform_device.h>
+
+#include <asm/mach-ath79/ath79.h>
+#include <asm/mach-ath79/ar71xx_regs.h>
+
+#include "common.h"
+#include "dev-eth.h"
+#include "dev-gpio-buttons.h"
+#include "dev-leds-gpio.h"
+#include "dev-m25p80.h"
+#include "dev-usb.h"
+#include "dev-wmac.h"
+#include "machtypes.h"
+
+#define R36A_GPIO_LED_LAN 4
+#define R36A_GPIO_LED_STATUS 14
+#define R36A_GPIO_LED_USB 12
+#define R36A_GPIO_LED_WAN 16
+#define R36A_GPIO_LED_WLAN 15
+
+#define R36A_GPIO_WDT_EN 1
+#define R36A_GPIO_WDT_IN 0
+#define R36A_GPIO_USB_PWR 3
+
+#define R36A_GPIO_BTN_RESET 2
+#define R36A_GPIO_BTN_RFKILL 17
+
+#define R36A_KEYS_POLL_INTERVAL 20
+#define R36A_KEYS_DEBOUNCE_INTERVAL (3 * R36A_KEYS_POLL_INTERVAL)
+
+#define R36A_WMAC_CALDATA_OFFSET 0x1000
+
+static struct gpio_led r36a_leds_gpio[] __initdata = {
+ {
+ .name = "r36a:blue:lan",
+ .gpio = R36A_GPIO_LED_LAN,
+ .active_low = 1,
+ }, {
+ .name = "r36a:blue:status",
+ .gpio = R36A_GPIO_LED_STATUS,
+ .active_low = 1,
+ }, {
+ .name = "r36a:blue:usb",
+ .gpio = R36A_GPIO_LED_USB,
+ .active_low = 1,
+ }, {
+ .name = "r36a:blue:wan",
+ .gpio = R36A_GPIO_LED_WAN,
+ .active_low = 1,
+ }, {
+ .name = "r36a:blue:wlan",
+ .gpio = R36A_GPIO_LED_WLAN,
+ .active_low = 1,
+ },
+};
+
+static struct gpio_keys_button r36a_gpio_keys[] __initdata = {
+ {
+ .desc = "reset",
+ .type = EV_KEY,
+ .code = KEY_RESTART,
+ .debounce_interval = R36A_KEYS_DEBOUNCE_INTERVAL,
+ .gpio = R36A_GPIO_BTN_RESET,
+ .active_low = 1,
+ }, {
+ .desc = "rfkill",
+ .type = EV_KEY,
+ .code = KEY_RFKILL,
+ .debounce_interval = R36A_KEYS_DEBOUNCE_INTERVAL,
+ .gpio = R36A_GPIO_BTN_RFKILL,
+ .active_low = 1,
+ },
+};
+
+static void __init r36a_setup(void)
+{
+ u8 *art = (u8 *) KSEG1ADDR(0x1f070000);
+
+ ath79_register_m25p80(NULL);
+
+ ath79_setup_ar933x_phy4_switch(false, false);
+
+ ath79_register_mdio(0, 0x0);
+
+ ath79_switch_data.phy4_mii_en = 1;
+ ath79_switch_data.phy_poll_mask = 0xf7;
+
+ /* LAN */
+ ath79_eth0_data.duplex = DUPLEX_FULL;
+ ath79_eth0_data.phy_if_mode = PHY_INTERFACE_MODE_MII;
+ ath79_eth0_data.phy_mask = BIT(4);
+ ath79_eth0_data.speed = SPEED_100;
+ ath79_init_mac(ath79_eth0_data.mac_addr, art, 0);
+ ath79_register_eth(0);
+
+ /* WAN */
+ ath79_eth1_data.duplex = DUPLEX_FULL;
+ ath79_eth1_data.phy_if_mode = PHY_INTERFACE_MODE_GMII;
+ ath79_init_mac(ath79_eth1_data.mac_addr, art, 1);
+ ath79_register_eth(1);
+
+ /* Disable JTAG (enables GPIO0-3) */
+ ath79_gpio_function_enable(AR934X_GPIO_FUNC_JTAG_DISABLE);
+
+ ath79_register_leds_gpio(-1, ARRAY_SIZE(r36a_leds_gpio),
+ r36a_leds_gpio);
+
+ ath79_register_gpio_keys_polled(-1, R36A_KEYS_POLL_INTERVAL,
+ ARRAY_SIZE(r36a_gpio_keys),
+ r36a_gpio_keys);
+
+ gpio_request_one(R36A_GPIO_WDT_IN,
+ GPIOF_OUT_INIT_LOW | GPIOF_EXPORT_DIR_FIXED,
+ "WDT input");
+
+ gpio_request_one(R36A_GPIO_WDT_EN,
+ GPIOF_OUT_INIT_LOW | GPIOF_EXPORT_DIR_FIXED,
+ "WDT enable");
+
+ gpio_request_one(R36A_GPIO_USB_PWR,
+ GPIOF_OUT_INIT_HIGH | GPIOF_EXPORT_DIR_FIXED,
+ "USB power");
+
+ ath79_register_wmac(art + R36A_WMAC_CALDATA_OFFSET, NULL);
+
+ ath79_register_usb();
+}
+
+MIPS_MACHINE(ATH79_MACH_R36A, "R36A", "ALFA Network R36A", r36a_setup);
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h b/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h
index 40ac034388..4afda05638 100644
--- a/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h
+++ b/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h
@@ -166,6 +166,7 @@ enum ath79_mach_type {
ATH79_MACH_PB44, /* Atheros PB44 reference board */
ATH79_MACH_PQI_AIR_PEN, /* PQI Air Pen */
ATH79_MACH_QIHOO_C301, /* Qihoo 360 C301 */
+ ATH79_MACH_R36A, /* ALFA Network R36A */
ATH79_MACH_R602N, /* P&W R602N */
ATH79_MACH_R6100, /* NETGEAR R6100 */
ATH79_MACH_RAMBUTAN, /* 8devices Rambutan */
diff --git a/target/linux/ar71xx/generic/config-default b/target/linux/ar71xx/generic/config-default
index 15116f5500..06d5223d6c 100644
--- a/target/linux/ar71xx/generic/config-default
+++ b/target/linux/ar71xx/generic/config-default
@@ -120,6 +120,7 @@ CONFIG_ATH79_MACH_PB42=y
CONFIG_ATH79_MACH_PB44=y
CONFIG_ATH79_MACH_PQI_AIR_PEN=y
CONFIG_ATH79_MACH_QIHOO_C301=y
+CONFIG_ATH79_MACH_R36A=y
CONFIG_ATH79_MACH_R602N=y
CONFIG_ATH79_MACH_RE450=y
CONFIG_ATH79_MACH_RUT9XX=y
diff --git a/target/linux/ar71xx/image/generic.mk b/target/linux/ar71xx/image/generic.mk
index 3fbfca35e0..b7956ff54e 100644
--- a/target/linux/ar71xx/image/generic.mk
+++ b/target/linux/ar71xx/image/generic.mk
@@ -631,6 +631,18 @@ define Device/jwap230
endef
TARGET_DEVICES += jwap230
+define Device/r36a
+ DEVICE_TITLE := ALFA Network R36A
+ DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-usb-ledtrig-usbport -swconfig
+ BOARDNAME := R36A
+ SUPPORTED_DEVICES := r36a
+ IMAGE_SIZE := 15872k
+ MTDPARTS := spi0.0:384k(u-boot)ro,64k(u-boot-env),64k(art)ro,-(firmware)
+ IMAGE/sysupgrade.bin := append-kernel | pad-to $$$$(BLOCKSIZE) | \
+ append-rootfs | pad-rootfs | append-metadata | check-size $$$$(IMAGE_SIZE)
+endef
+TARGET_DEVICES += r36a
+
define Device/r602n
DEVICE_TITLE := P&W R602N
DEVICE_PACKAGES := kmod-usb-core kmod-usb2