aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-06-15 07:45:54 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-06-15 07:45:54 +0000
commitb5798e07a587a3c3ed769c8dc1755a7e973f8a99 (patch)
treed9a05ad2cc2424bd8d5ec79de489e8aceb6b06d1 /target
parent89aadeeae44eac5ef75d66d6cc5cdd33fb267e2f (diff)
downloadupstream-b5798e07a587a3c3ed769c8dc1755a7e973f8a99.tar.gz
upstream-b5798e07a587a3c3ed769c8dc1755a7e973f8a99.tar.bz2
upstream-b5798e07a587a3c3ed769c8dc1755a7e973f8a99.zip
ar71xx/image: add build step mkubntimage2 mkubntkernelimage for unifi boards
Signed-off-by: Alexander Couzens <lynxis@fe80.eu> SVN-Revision: 45982
Diffstat (limited to 'target')
-rw-r--r--target/linux/ar71xx/image/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 750de9c3cd..6662672d2d 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -131,8 +131,30 @@ define Build/mkubntimage-split
rm $@.old1 $@.old2
endef
+define Build/mkubntimage2
+ $(STAGING_DIR_HOST)/bin/mkfwimage2 -f 0x9f000000 \
+ -v $(UBNT_TYPE).$(UBNT_CHIP).v6.0.0-OpenWrt-$(REVISION) \
+ -p jffs2:0x50000:0xf60000:0:0:$@ \
+ -o $@.new
+ @mv $@.new $@
+endef
+
DEVICE_VARS += UBNT_BOARD UBNT_CHIP UBNT_TYPE
+define Build/mkubntkernelimage
+ rm -rf $(KDIR_TMP)/ubnt-$(KERNEL_IMAGE)/image && \
+ mkdir -p $(KDIR_TMP)/ubnt-$(KERNEL_IMAGE)/image && \
+ cp $@ $(KDIR_TMP)/ubnt-$(KERNEL_IMAGE)/image/kernel0 && \
+ $(STAGING_DIR_HOST)/bin/mkfs.jffs2 \
+ --pad --big-endian --squash-uids -v -e 64KiB \
+ -o $@.new \
+ -d $(KDIR_TMP)/ubnt-$(KERNEL_IMAGE)/image \
+ 2>&1 && \
+ $(STAGING_DIR_HOST)/bin/padjffs2 $@.new -J 64
+ -rm -rf $(KDIR_TMP)/ubnt-$(KERNEL_IMAGE)/image
+ @mv $@.new $@
+endef
+
define Device/Default
BOARDNAME :=
DEVICE_PROFILE = $$(BOARDNAME)